Autotext nach Eingabewert (WENN(UND) mit entsprechender bedingter Formatierung

27/08/2008 - 09:05 von Sarah | Report spam
Guten Morgen zusammen,

Teil A (Formel in Spalte J):

anhand der letzten Beitràge konnte ich die folgende Formel (enthalten
in Spalte J) zusammenstellen (Matrixformel):

{
=WENN(UND(C3:F3="x");"Bestàtigung
abwarten";WENN(UND(G3="x");"Abgeschlossen mit
Bestàtigung";WENN(UND(H3="x");"Kündigung
abwarten";WENN(UND(I3="x");"Abgeschlossen mit Kündigung";"Offen"))))
}

Leider ignoriert meine Formel die "x" Eingaben im Bereich C3:F3.
Mein Status springt nie zu "Bestàtigung abwarten". Woran kann das
liegen?

Teil B (bedingte Formatierung in Spalte J):

Entsprechend des automatischen Status sollte auch die Zelle formatiert
sein.

Format1
"Offen" = rot (man muss also was tun) -> bedingte Formatierung Zelle
gleich "Offen" geht wunderbar

Format2:
"... abwarten" = orange (man muss was tun aber muss erst drauf warten)
-> bedingte Formatierung
Formel dazu habe ich:
="SUCHENB(""abwarten"";J3:J64;"")"

Leider geht das nicht wie ich es mir vorgestellt habe. Ich wollte in
einem bereich nach "abwarten" suchen und wenn enthalten dann soll es
orange sein.

Format3:
"Abgeschlossen..." = grün (alles erledigt) -> bedingte Formatierung
Formel dazu habe ich:
="SUCHENB(""Abgeschlossen"";J3:J64;"")"

Selbes Problem wie bei Format2.

Ich habe einen Screenshot gemacht, damit mian sich das ganze ein wenig
besser vorstellen kann.
http://img411.imageshack.us/img411/...stenj3.png

Kann mir jemand weiterhelfen?

Danke und Gruß,
Sarah
 

Lesen sie die antworten

#1 Melanie Breden
27/08/2008 - 09:40 | Warnen spam
Hallo Sarah,

"Sarah" schrieb:
Leider ignoriert meine Formel die "x" Eingaben im Bereich C3:F3.
Mein Status springt nie zu "Bestàtigung abwarten". Woran kann das
liegen?



wenn ich das richtig sehe, dann soll die erste Wenn-Prüfung den Text liefern,
wenn in einer der angegebenen Zellen ein "x" steht?
Dann musst du keine UND, sondern eine ODER-Funktion verwenden:

{=WENN(ODER(C3:F3="x");"Bestàtigung abwarten";
WENN(G3="x";"Abgeschlossen mit Bestàtigung";
WENN(H3="x";"Kündigung abwarten";
WENN(I3="x";"Abgeschlossen mit Kündigung";"Offen"))))}

Entsprechend des automatischen Status sollte auch die Zelle formatiert
sein.



Format2:
"... abwarten" = orange (man muss was tun aber muss erst drauf warten)
-> bedingte Formatierung
Formel dazu habe ich:
="SUCHENB(""abwarten"";J3:J64;"")"

Markiere den Bereich J3:J64 und hinterlege folgende Formel:
=SUCHEN("abwarten";J3)

Für Format3 entsprechend anpassen.

Mit freundlichen Grüssen
Melanie Breden

- Microsoft MVP für Excel -
www.melanie-breden.de
Das Excel-VBA Codebook 2007 http://tinyurl.com/2nwvod

Ähnliche fragen