AVM Fritz!Card USB Isdn - (k)ubuntu 8.04 (hardy)

22/11/2008 - 13:25 von Dieter Schmickler | Report spam
Hallo,

ich versuche, bisher erfolglos, die AVM Fritz!Card USB 2.1 Isdn als
Faxserver / Anrufbeantworter zu installieren. Die manuelle Compilierung
von fcusb2 scheitert aber an:

[.]
/home/dieter/download/avm/2.6.24-21/src/driver.c:95: Warnung: »int« ist
Standardtyp in Deklaration von »DECLARE_MUTEX_LOCKED«
/home/dieter/download/avm/2.6.24-21/src/driver.c:95: Warnung:
Parameternamen (ohne Typen) in Funktionsdeklaration
/home/dieter/download/avm/2.6.24-21/src/driver.c:96: Warnung: »int« ist
Standardtyp in Deklaration von »DECLARE_MUTEX_LOCKED«
/home/dieter/download/avm/2.6.24-21/src/driver.c:96: Warnung:
Parameternamen (ohne Typen) in Funktionsdeklaration
/home/dieter/download/avm/2.6.24-21/src/driver.c: In Funktion
»start_closing_worker«:
/home/dieter/download/avm/2.6.24-21/src/driver.c:790: Warnung: Zuweisung
von inkompatiblem Zeigertyp
/home/dieter/download/avm/2.6.24-21/src/driver.c: In Funktion »scheduler«:
/home/dieter/download/avm/2.6.24-21/src/driver.c:1214: Fehler: »hotplug«
nicht deklariert (erste Benutzung in dieser Funktion)
/home/dieter/download/avm/2.6.24-21/src/driver.c:1214: Fehler: (Jeder
nicht deklarierte Bezeichner wird nur einmal aufgeführt
/home/dieter/download/avm/2.6.24-21/src/driver.c:1214: Fehler: für jede
Funktion in der er auftritt.)
/home/dieter/download/avm/2.6.24-21/src/driver.c: In Funktion
»kill_thread«:
/home/dieter/download/avm/2.6.24-21/src/driver.c:1249: Fehler: »hotplug«
nicht deklariert (erste Benutzung in dieser Funktion)
make[2]: *** [/home/dieter/download/avm/2.6.24-21/src/driver.o] Fehler 1
make[1]: *** [_module_/home/dieter/download/avm/2.6.24-21/src] Fehler 2
make[1]: Verlasse Verzeichnis '/usr/src/linux-headers-2.6.24-21-generic'
make: *** [fcusb2.o] Fehler 2
[.]

Wenn ich die verschiedenen Hinweise richtig gelesen habe, existiert ein
BUG in den linux-restricted-modules. Aber ich finde keinen Workaround um
den Fehler zu Beheben. Hat jemand einen Tip für mich?

Dieter
 

Lesen sie die antworten

#1 Oliver Föhr
22/11/2008 - 17:52 | Warnen spam
Dieter Schmickler schrieb:
Hallo,

ich versuche, bisher erfolglos, die AVM Fritz!Card USB 2.1 Isdn als
Faxserver / Anrufbeantworter zu installieren. Die manuelle Compilierung
von fcusb2 scheitert aber an:



Wo hast du Quellen her? Nimm das src.rpm von der SuSE11.0 das sollte für deinen
Kernel passen.


http://opensuse.foehr-it.de


hth

olly

Ähnliche fragen