AVM Fritz USB Stick unter SUSE 11.1

16/01/2009 - 16:10 von Ulrich Graefe | Report spam
Hallo,

ich versuche jetzt ca. das 20. Mal meinen AVM Fritz USB Stick ter SUSE 11.1
zu installieren.

1) Zuerst mit der Anleitung von AVM: hier komme ich bis zum Entpacken der
Datei fwlan usb. Nach ./install bekomme ich dann folgende Fehlermeldung:

"ux-4x7y:/home/ulrich/Wlantreiber/fritz # ./install
make: Entering directory `/home/ulrich/Wlantreiber/fritz/src'
rm -f main.o driver.o tools.o lib.o buffers.o wext.o
rm -f fwlanusb.o fwlanusb.ko
make: Leaving directory `/home/ulrich/Wlantreiber/fritz/src'
make: Entering directory `/home/ulrich/Wlantreiber/fritz/src'
make -C /lib/modules/2.6.27.7-9-pae/build
SUBDIRS=/home/ulrich/Wlantreiber/fritz/src modules
make[1]: Entering directory `/usr/src/linux-2.6.27.7-9-obj/i386/pae'
make -C ../../../linux-2.6.27.7-9 O=/usr/src/linux-2.6.27.7-9-obj/i386/pae/.
modules
CC [M] /home/ulrich/Wlantreiber/fritz/src/main.o
In file included from /home/ulrich/Wlantreiber/fritz/src/tools.h:30,
from /home/ulrich/Wlantreiber/fritz/src/main.c:31:
/home/ulrich/Wlantreiber/fritz/src/defs.h:63: error: redefinition of typedef
'uintptr_t'
/usr/src/linux-2.6.27.7-9/include/linux/types.h:40: error: previous
declarationof 'uintptr_t' was here
make[4]: *** [/home/ulrich/Wlantreiber/fritz/src/main.o] Error 1
make[3]: *** [_module_/home/ulrich/Wlantreiber/fritz/src] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.27.7-9-obj/i386/pae'
make: *** [fwlanusb.o] Error 2
make: Leaving directory `/home/ulrich/Wlantreiber/fritz/src'
make: Entering directory `/home/ulrich/Wlantreiber/fritz/src'
cp: cannot stat `fwlanusb.ko': No such file or directory
make: *** [install] Error 1
make: Leaving directory `/home/ulrich/Wlantreiber/fritz/src'
linux-4x7y:/home/ulrich/Wlantreiber/fritz #"

Da ich hier nicht weitergekommen bin, habe ich dann 2) die Anleitung von der
Opensuse.de Homepage mit dem Ndiswrapper und dem Windowstreiber versucht.
Es ließ sich im Ndiswrapper der Treiber fwlanusb sowie auch versuchsweise
der 2. in dem Ordner vorhandene .inf-Treiber installieren, die Treiber
wurden auch bei Auslesen der installierten Treiber angezeigt. Nun ließ auch
im Yast in der Netzwerkkonfiguration mit Eingabe des Moduls "Ndiswrapper"
der Stick installieren, das Problem der fehlenden Firmware wurde dort nicht
mehr angezeigt. Bei Abschluss der Konfiguration wurde dann vom System
angegeben, ob die erkannte Ndiswrapperkonfiguration per "modprobe"
integriert werden sollte, hierbei gab es keine Probleme. Eine Wlanverbindung
wurde im NetworkManager dann trotzdem nicht ermöglicht, da "kein Tràger auf
et0".

Insgesamt habe ich nun bereits 5 verschiedene Installationanleitungen mit
jeweils verschiedenen / Wegen / Befehlen versucht.
Bitte keine sehr schlauen Kommentare, bin relativer Linux Neuling.

Kann jemand auf dem einen oder anderen Weg Hilfe anbieten ?

Uli
 

Lesen sie die antworten

#1 Torsten Kaiser
16/01/2009 - 17:31 | Warnen spam
Hallo Ulrich,

Ulrich Graefe wrote:

[...]
Eine
Wlanverbindung wurde im NetworkManager dann trotzdem nicht ermöglicht, da
"kein Tràger auf et0".



Es hat schon vereinzelte Rà¼ckmeldungen gegeben, daàŸ unmittelbar nach einem
Online-Update keine Netzwerkverbindung via Networkmanager mehr möglich war.
Workaround war ein Schwenk zur klassischen Vernetzungsmethode
(ifup/ifdown). Von einer Entwarnung habe ich bisher nichts gelesen.

Wenn Dein Rechner nicht anderweitig vernetzt ist, könnte das die Ursache fà¼r
die letzten Probleme sein.

AuàŸerdem meldet sich eine einsame WLAN-Karte normalerweise mit "wlan0". Kann
es sein, daàŸ Du beim Konfigurieren als Netzwerktyp nicht
ausdrà¼cklich "Wireless" ausgewà¤hlt hast? Ist mir bei 11.0 auch passiert.
AuàŸerdem ist dort als Startmodus "bei Kabelverbindung" voreingestellt. Ich
suche heute noch im Schlaf nach dem mitgelieferten WLAN-Kabel...

Die YAST-Konfiguration ist bei Ndiswrapper-Konfigurationen ein
Einweg-Dialog. Denn Ndiswrapper fà¤llt irreversibel auf die Nase, wenn er im
vollen Lauf ein zweites Mal von Yast gestartet wird.

Deshalb mein Rezeptvorschlag (schon gekocht fà¼r Atheros auf 11.0):

1. manuell hinzugefà¼gte Konfiguration löschen.
Tut eh nicht...

2. Rechner kalt durchstarten (landen/stromlos/starten)
Ndiswrapper ist auch nach dem Löschen der Konfiguration noch aktiv und là¤àŸt
sich auch nicht so ohne weiteres restlos beenden.

3. Yast-Konfiguration OHNE Start der erkannten Ndiswrapper-Konfiguration
Dabei wird nà¤mlich das Ndiswrapper-Modul geladen, das Du nachher als
Kartentreiber angibst und so beim AbschluàŸ der Konfiguration ein zweites
Mal startest.

4. Konfiguration EINGABEFEHLERFREI in einem Rutsch eingeben.
Kleinigkeiten wie Zahlendreher in der ESSID oder im PaàŸwort können hinter
den Kulissen in der /etc/sysconfig/network/ifcfg-wlan0 korrigiert werden.
Prinzipielle Fehleinstellungen prinzipiell auch, da muàŸ man dann aber schon
die richtigen Schlà¼sselwörter inklusive Syntax wissen. <sarcasm>Lernst Du
alle in den nà¤chsten zwei Wochen...</sarcasm>

5. Rechner kalt durchstarten (landen/stromlos/starten)
Um sicherzustellen, daàŸ Ndiswrapper beim Starten kein halbfertiges
Firmware-Modul im Weg steht.

Sobald Du mit ifconfig eine wlan0 siehst, baut Dein Stick schon eine
WLAN-Wolke auf. Deren Konfigurationsdetails kann man sich auf die Schnelle
auch mit iwconfig anschauen.

Wenn Du dann noch Kleinigkeiten an der Konfiguration der Wolke à¤ndern muàŸt,
am besten zu FuàŸ in der /etc/sysconfig/network/ifcfg-wlan0. Danach das
Netzwerk rebooten mit "/etc/rc.d/network restart".

Viele Grà¼àŸe aus Hamburg
Torsten Kaiser

Ähnliche fragen