avrdude: JTAG ICE mkII hält XMega an

09/02/2015 - 23:34 von Johannes Bauer | Report spam
Hallo Gruppe,

habe unter Linux einen XMega128A1 am laufen, den ich mittels eines
JTAGICE mkII und avrdude 6.0.1 programmiere.

Das Programmieren und Zurücklesen von Programmen funktioniert auch
prima. Nachdem ich allerdings den JTAG angesprochen habe, làuft der
XMega nicht los, sondern wird irgendwie angehalten. Wenn ich dann den
Kippschalter am JTAGICE aus- und wieder anschalte, làuft das Programm los.

Es reicht, dass ich nur den Xmega mittels avrdude resette, also:

$ avrdude -V -P usb -p x128a1 -c jtagmkII

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.01s

avrdude: Device signature = 0x1e974c

avrdude done. Thank you.

Damit er in seinem "halt" Modus stekcenbleibt. Der wird dann auch nicht
aufgelöst, wenn ich den JTAG-Connector abziehe, sondern erst, wenn ich
den Kippschalter aus- und anmache (oder natürlich den JTAG-Connector
abstecke und dann das ganze System resette).

Weiß jemand warum das so ist und wie man den in Software dazu bringt,
loszulaufen?

Viele Grüße,
Johannes



Wo hattest Du das Beben nochmal GENAU vorhergesagt?


Zumindest nicht öffentlich!


Ah, der neueste und bis heute genialste Streich unsere großen
Kosmologen: Die Geheim-Vorhersage.
- Karl Kaos über Rüdiger Thomas in dsa <hidbv3$om2$1@speranza.aioe.org>
 

Lesen sie die antworten

#1 Marc Santhoff
10/02/2015 - 16:05 | Warnen spam
Johannes Bauer schrieb:

Hallo Gruppe,

habe unter Linux einen XMega128A1 am laufen, den ich mittels eines
JTAGICE mkII und avrdude 6.0.1 programmiere.


[...]
Weiß jemand warum das so ist und wie man den in Software dazu bringt,
loszulaufen?



man avrdude, Parameter -E

Marc

Ähnliche fragen