AXP - Detailbereich im Bericht zeigt nicht alle Datensaetze an

24/09/2007 - 11:00 von Rainer Georg Blankenagel | Report spam
Hallo zusammen,

ich sitze scheinbar mal wieder auf meinen Synapsen und finde auf den
üblichen Wegen (FAQ/Web/MitderStirnaufdieTischkanteschlagen) keinen Ansatz,
wo mein Problem liegen könnte.

System: WinXP mit allen Updates, Access XP mit SP3.

Ich habe einen Rechnungsbericht, der nach einer Bestellnummer gruppiert
ist. Die Eigenschaft "Zusammenhalten" steht auf 'Ganze Gruppe'. In einer
Rechnung, die mehr Datensàtze enthàlt, als auf eine Seite passen, sollte
der Detailbereich sich ja eigentlich passend bis auf die zweite Seite
wiederholen und danach der Gruppenfuß angezeigt werden. Tut er aber nicht.

Der Gruppenfuß steht stattdessen am Ende der ersten Seite, die letzten
Datensàtze des Detailbereichs werden nirgendwo angezeigt. Der Gruppenfuß
zeigt aber die korrekte Rechnungssumme für alle (auch die nicht sichtbaren)
Rechnungsposten an. Die zweite Seite enthàlt nur noch den Seitenkopf,
einige Kommentarfelder aus dem Berichtsfuß und den Seitenfuß.

Ich finde keine Eigenschaft von Detailbereich, Gruppenfuß oder dem Bericht
selbst, die ich da verantwortlich machen kann.

Hat jemand eine Idee, wo das Problem liegen kann?


Grüße aus Köln,

Rainer
 

Lesen sie die antworten

#1 Thomas Möller
24/09/2007 - 21:32 | Warnen spam
Hallo Rainer,

Rainer Georg Blankenagel schrieb:
Ich habe einen Rechnungsbericht, der nach einer Bestellnummer
gruppiert ist. Die Eigenschaft "Zusammenhalten" steht auf 'Ganze
Gruppe'. In einer Rechnung, die mehr Datensàtze enthàlt, als auf eine
Seite passen, sollte der Detailbereich sich ja eigentlich passend bis
auf die zweite Seite wiederholen und danach der Gruppenfuß angezeigt
werden. Tut er aber nicht.

Der Gruppenfuß steht stattdessen am Ende der ersten Seite, die letzten
Datensàtze des Detailbereichs werden nirgendwo angezeigt. Der
Gruppenfuß zeigt aber die korrekte Rechnungssumme für alle (auch die
nicht sichtbaren) Rechnungsposten an. Die zweite Seite enthàlt nur
noch den Seitenkopf, einige Kommentarfelder aus dem Berichtsfuß und
den Seitenfuß.

Ich finde keine Eigenschaft von Detailbereich, Gruppenfuß oder dem
Bericht selbst, die ich da verantwortlich machen kann.

Hat jemand eine Idee, wo das Problem liegen kann?



befindet sich VBA-Code in Deinem Bericht?
Wenn ja, welcher Code in welchem Ereignis?

CU
Thomas

Homepage: www.Team-Moeller.de

Ähnliche fragen