Bedingt aus anderem Blatt summieren

22/06/2009 - 18:53 von Alexander Goetzenstein | Report spam
Hallo,
ich habe hier eine Excel-Datei mit zwei Blàttern.

Blatt1:
"""""""
A B C
1 1368 1457 901
2 Berlin Muenchen Stuttgart
3 Koeln Bonn
4 Atlantis


Blatt2:
"""""""
A B
1 Atlantis 234
2 Berlin 345
3 Bonn 567
4 Koeln 789
5 Muenchen 890
6 Stuttgart 901


Dabei werden die Eintràge der Namen in Blatt 1 per Gleichung erzeugt,
z.B. in A2:
='Blatt2'!$A$2
-im wesentlichen, um Tippfehler auszuschließen.

Die Zahlen darüber soll die Summe sein der Zahlen, die in Blatt2 neben
den Namen in Spalte B stehen, also in Blatt1, Spalte A:
Berlin + Koeln + Atlantis --> 345 + 789 + 234 = 1368

Ich meine zwar, so etwas schon einmal hingekriegt zu haben, aber es will
mir nicht erneut gelingen: wie formuliere ich eine passende Formel?

Gruß
Alex
 

Lesen sie die antworten

#1 Alexander Wolff
22/06/2009 - 19:39 | Warnen spam
Du könntest in Tab1!A1 schreiben:

=SUMMENPRODUKT(SUMMEWENN(Tab2!$A$1:$A$6;A2:A4;Tab2!$B$1:$B$6))

und nach rechts bis C1 kopieren. Ungetestet.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen