Bedingte Feldausgabe

15/05/2008 - 11:03 von Arthur | Report spam
Guten Tag,
ich möchte einen Textwert ausgeben in Tabellenblatt1 ausgeben und eine
Bedingung daran knüpfen. Dort steht in Spalte "a" der Suchwert. Mit diesem
Wert soll dann in Tabellenblatt2 in Spalte "a" gesucht werden. Wenn der
Suchwert gefunden wird, dann soll er die Spalte "b" ausgeben, wenn dieser
Suchwert nicht gefunden wird, dann soll der Text "Nicht vorhanden" ausgegeben
werden.
Anbei die zwei Tabellenblàtter.
Vielen Dank schon einmal vorab.
Gruß
Arthur

Tabellenblatt1
1
2
3
4
5

Tabellenblatt2
2 J
4 N
 

Lesen sie die antworten

#1 Robert Gelbmann
15/05/2008 - 11:50 | Warnen spam
Hallo Arthur!

"Arthur" schrieb ...
Guten Tag,
ich möchte einen Textwert ausgeben in Tabellenblatt1 ausgeben und
eine
Bedingung daran knüpfen. Dort steht in Spalte "a" der Suchwert. Mit
diesem
Wert soll dann in Tabellenblatt2 in Spalte "a" gesucht werden. Wenn
der
Suchwert gefunden wird, dann soll er die Spalte "b" ausgeben, wenn
dieser
Suchwert nicht gefunden wird, dann soll der Text "Nicht vorhanden"
ausgegeben
werden.



Ein Paradebeispiel für die SVERWEIS-Funktion!

Ich nehme mal an, die Daten haben jeweils eine Kopfzeile in der Zeile 1
und es gibt zB insgesamt 100 Zeilen am Blatt Tabelleblatt2.

In B2 am Blatt Tabellenblatt1:
=SVERWEIS($A2;Tabellenblatt2!$A$2:$B$100;2;FALSCH)

Die Funktion liefert dir dann das gewünschte Ergebnis aus der 2. Spalte
des Bereiches A2:B100 am Blatt Tabellenblatt2.
Wird der Suchwert nicht gefunden, so liefert die Funktion die
Fehlermeldung #NV (Nicht verfügbar).

Um die Formel so zu erweitern, dass sie - wie gewünscht - den Wert
"Nicht vorhanden" ausgibt, wàre es jetzt nützlich zu wissen, welche
Excel-Version zu verwendest (Bitte immer angeben!!).

In Excel 2007:
=WENNFEHLER(SVERWEIS($A2;Tabellenblatt2!$A$2:$B$100;2;FALSCH);"Nicht
verfügbar")

In àlteren Versionen gibt es diese Funktion aber noch nicht und es wird
daher lànger und komplexer (und laaangsamer, was aber nur bei sehr
vielen Formeln problematisch wird):
=WENN(ISTNV(SVERWEIS($A2;Tabellenblatt2!$A$2:$B$100;1;FALSCH));"Nicht
verfügbar";SVERWEIS($A2;Tabellenblatt2!$A$2:$B$100;2;FALSCH))


In der Hoffnung geholfen zu haben, verbleibe ich mit einem leisen


Servus aus Wien,
-Robert Gelbmann-

The world is quiet here.

Ähnliche fragen