Bedingte Formatierung klappt in gleicher DB in 00 aber nicht in 03

16/09/2008 - 08:22 von Thomas Keller | Report spam
Hallo NG,

ich suchte gerade eine Erklàrung für folgendes Phànomen:
in meiner A00-DB habe ich meinem Feld die bedingte Formatierung gegeben
[offen]=-1, dann rotes Muster
diese bedingte Formatierung hat die gleiche Datenbank in A03 nicht
angezeigt.
Löschen und Neuerstellung der bedingten Formatierung in A00 hat nix
gebracht, die Suche in der Newsgroup auch nichts.

Ich habe rumprobiert und für mich einen workaround gefunden, wàhrend ich
eine Newsgroup-Frage formulierte, deswegen hier die Problemlösung statt
einer Frage:
Ich musste nicht nur die Bedingung löschen, sondern in der bedingung auf
"Feldwert" und dann DORT die seltsamerweise dort stehende bisherige und
eigentlich richtige Bedingung löschen. Dann auf "Ausdruck" und den gleichen
Ausdruck DORT nochmal eingeben. Macht eigentlich keinen Sinn, aber klappte.
Die Übernahme von Formatierungen aus einer A00-DB scheint manchmal
problematisch zu sein.

Meiner Meinung nach ein Fehler in A03, die Reproduzierbarkeit habe ich aber
jetzt nicht weiter getestet.

Gruß
Thomas

xp Sp2
00 SP3
03 SP3
 

Lesen sie die antworten

#1 Gottfried Lesigang
16/09/2008 - 09:03 | Warnen spam
Grüß dich Thomas!

[Problem mit der Bedingten Formatierung]



Ohne dieses Problem zu kennen trotzdem an dieser Stelle ein kleiner
Hinweis:

Ich setze die Bedingte Formatierung immer im Form_Load-Ereignis per Code.
Die Vorteile: Man kann Farben etc. aus Settings holen und man kann
dynamisch auf Zustànde reagieren.

Hier - aus dem Zusammenhang gerissener - Code, musst du halt anpassen...

Dim tmpFC As FormatCondition
Me.cboArtikelID.FormatConditions.Delete 'Alle entfernen
Set tmpFC = Me.cboArtikelID.FormatConditions.Add(acExpression, , _
"Len(Trim(Nz([Forms]![EinForm]![EinUFrm].[Form]![EinFeld])))>0")
tmpFC.BackColor = SettingByName("AbgColor")
Set tmpFC = Nothing

Am besten in der OH mal mit FormatCondition suchen...

HTH
Gottfried

Home: www.develes.net
Mail:

Ähnliche fragen