Bedingte Formatierung

20/08/2009 - 14:56 von DirkDiggler96 | Report spam
Hallo liebe Experten,

folgendes Problem stellt sich mir:

Zunàchst habe ich eine Ampel erstellt(Zellen B6:B8).
Die Zellen B6:B8 sind wie dabei folgt formatiert:
Schriftart: Webdings, Schriftgröße 16, Hintergrundfarbe schwarz,
Schriftfarbe grau
In der Zelle steht der Buchstabe n
(Der Buchstabe n ergibt dann in Schriftart Webdings einen Kreis)

Weiterhin habe ich eine Tabelle(relevante Spalte ist von D17:D30) in der
verschiedene Statusse von Projekten dargestellt werden sollen. In diese
Tabelle kommt jeden Monat eine neue Zeile mit dem aktuellen Projektstatus.

Das Ziel ist, in der Tabelle den aktuellen Status einzutragen(ich trage in
die Zelle "grün", "gelb" oder "rot" ein) und dann automatisch in der Ampel
die Farbe zu erhalten, die unten in der Tabelle eingetragen wurde.
z.B. ist nach dem ersten Monat alles ok und ich trage "grün" in die Tabelle
ein, die Ampel soll grün zeigen.
im zweiten Monat geht einiges schief, das Projekt wird auf rot gesetzt(in
der zweiten Zeile der Tabelle trage ich "rot" ein, in der ersten Zeile bleibt
weiterhin "grün" stehen). Die Ampel soll auch rot zeigen, das grün aus dem
Vormonat aber soll verschwinden(nicht in der Tabelle, sondern nur so, dass
die Ampel dann nur noch rot zeigt).

Bisher habe ich es über bedingte Formatierungen versucht.
Also die Zelle B6 wie folgt formatiert:
=WENN(ISTLEER($D18);$D17;$D18)="grün" und mehrere Bedingungen (jeweils eine
Zelle weiter, also als nàchstes $D19;$D18;$D19)hinzugefügt, damit immer nur
ein "grün" zàhlt(deswegen die ISTLEER-Funktion)
damit hab ich es geschaftt, dass, wenn ich in Zelle D21 oder so "grün"
eintrage, das "grün" aus Zelle D18 nicht mehr zàhlt. Leider sind in der Ampel
dann aber die Farben rot und grün, wenn ich einmal rot eingetragen habe, denn
die Ampel besteht ja aus drei Zellen die unabhàngig voneinander sind.

Ich hoffe ich konnte mich hablwegs verstàndlich ausdrücken und es gibt da
draussen jemanden der mir helfen kann

Beste Grüße
Dirk
 

Lesen sie die antworten

#1 Claus Busch
20/08/2009 - 15:22 | Warnen spam
Hallo Dirk,

Am Thu, 20 Aug 2009 05:56:02 -0700 schrieb DirkDiggler96:

Das Ziel ist, in der Tabelle den aktuellen Status einzutragen(ich trage in
die Zelle "grün", "gelb" oder "rot" ein) und dann automatisch in der Ampel
die Farbe zu erhalten, die unten in der Tabelle eingetragen wurde.
z.B. ist nach dem ersten Monat alles ok und ich trage "grün" in die Tabelle
ein, die Ampel soll grün zeigen.
im zweiten Monat geht einiges schief, das Projekt wird auf rot gesetzt(in
der zweiten Zeile der Tabelle trage ich "rot" ein, in der ersten Zeile bleibt
weiterhin "grün" stehen). Die Ampel soll auch rot zeigen, das grün aus dem
Vormonat aber soll verschwinden(nicht in der Tabelle, sondern nur so, dass
die Ampel dann nur noch rot zeigt).



markiere B6 und gehe auf bedingte Formatierung => Formel:
=INDEX(D:D;VERGLEICH("";D:D;-1))="rot" Format:Schriftfarbe rot.
Markiere dann B7
=INDEX(D:D;VERGLEICH("";D:D;-1))="gelb" Format: Schriftfarbe gelb.
B8 analog dazu in grün.


Mit freundlichen Grüssen
Claus Busch
Win XP PRof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen