bei Tabellen verlinkt = Fehler

22/10/2008 - 11:44 von Steffen Brose | Report spam
Hallo Allseits,
ich habe mal folgende Anfrage / Problem:

Ich starte synchrone Fo's mit:

Private Sub Form_Current()
Set rs = Forms!Fo_01_Start!MeinFormular200.Form.RecordsetClone
rs.FindFirst "Id = " & Me!ID
If Not rs.NoMatch Then
Forms!Fo_01_Start!MeinFormular200.Form.Bookmark = rs.Bookmark
End If
Set rs = Nothing
End Sub

- wenn die Tabellen in der mdb drin stehen = kein Problem - funktioniert

- ich möchte aber die Trennung in FE und BE ... und wenn dann die
Tabellen im BE stehen - gibt es gleich nach Fo-Start Fehlermeldung:
bei Zeile:

Set rs = Forms!Fo_01_Start!MeinFormular200.Form.RecordsetClone

Laufzeitfehler '2455'
Sie haben einen Ausdruck eingegeben, der einen unzulàssigen Verweis
auf die Eigenschaft Form/Report enthàlt.


Gibt es da eine Möglichkeit zur Fehlerbeseitigung ?
Vielen Dank für
Eure Hilfe - Gruß Steffen
 

Lesen sie die antworten

#1 Mark Doerbandt
22/10/2008 - 11:54 | Warnen spam
Hallo, Steffen,

Steffen Brose:

Ich starte synchrone Fo's mit:

Private Sub Form_Current()
Set rs = Forms!Fo_01_Start!MeinFormular200.Form.RecordsetClone
rs.FindFirst "Id = " & Me!ID
If Not rs.NoMatch Then
Forms!Fo_01_Start!MeinFormular200.Form.Bookmark = rs.Bookmark
End If
Set rs = Nothing
End Sub

- wenn die Tabellen in der mdb drin stehen = kein Problem - funktioniert

- ich möchte aber die Trennung in FE und BE ... und wenn dann die
Tabellen im BE stehen - gibt es gleich nach Fo-Start Fehlermeldung:
bei Zeile:

Set rs = Forms!Fo_01_Start!MeinFormular200.Form.RecordsetClone

Laufzeitfehler '2455'
Sie haben einen Ausdruck eingegeben, der einen unzulàssigen Verweis
auf die Eigenschaft Form/Report enthàlt.



wenn der Code eh im Formular selbst steht: warum nicht Me verwenden?

Set rs = Me.RecordsetClone

Gruss - Mark

Informationen fuer Neulinge in den Access-Newsgroups unter
http://www.doerbandt.de/Access/Newbie.htm

Bitte keine eMails auf Newsgroup-Beitràge senden.

Ähnliche fragen