Bei veränderten Zellwerten automatisch akutalisieren - geht nicht

22/06/2009 - 13:38 von m-mahle | Report spam
Hallo Forum,

habe gerade ein komisches Problem mit Excel 2007:

Ich erzeuge mit SQL eine Abfrage mit 3 Parametern auf eine Datenbank namens
BDE1, Tabelle Einzelprozess:
SELECT * FROM |BDE1|.|EINZELPROZESS| WHERE |EINZELPROZESS|.|EINPROZESSART| =
? AND |EINZELPROZESS|.|EINIPADRESSE|= ? AND |EINZELPROZESS|.|EINPROZESSDAT| =
?

Das erste ? ist die Prozessart, das sind einzelne Nummern von 20000 bis 20015.
Das zweite ? ist die IP-Adresse einer Produktionsmaschine, von der die Daten
stammen.
Das dritte ? ist das Abfragedatum.

Jetzt habe ich bei allen drei Parametern die Funktion "bei verànderten
Zellwerten automatisch aktualisieren" angehakt. Das funktioniert so aber
nicht.

Wenn ich die Parameter, die sich auf dem gleichen Datenblatt wie die
Datentabelle befinden àndere, wird nichts neu berechnet. Ich muss zuerst das
Icon für "Alles aktualisieren" drücken. Dann wird neu recherchiert und
aktualisiert.

Was mache ich falsch?

Grüße
Michael Mahle
 

Lesen sie die antworten

#1 m-mahle
22/06/2009 - 16:55 | Warnen spam
Hallo Forum,

ich habe den Fehler selber rausgefunden:

In der Dateibeschreibung wird wohl standardgemàß bei Password "Yes"
eingetragen. Da die Datei nicht schreibt, aber auf Datenbankebene bereits
Leserechte hat, funktioniert zwar der Aufruf und Datenimport, aber die
automatische Aktualisierung findet nicht statt. Interessant: Es wird auch
nicht nach dem Datenbankzugriff gefragt.

Nachdem ich die Passwortabfrage auf "No" gesetzt habe, geht auch die
automatische Aktualisierung bei Zellwertànderung.

Grüße
Michael Mahle



"m-mahle" schrieb:

Hallo Forum,

habe gerade ein komisches Problem mit Excel 2007:

Ich erzeuge mit SQL eine Abfrage mit 3 Parametern auf eine Datenbank namens
BDE1, Tabelle Einzelprozess:
SELECT * FROM |BDE1|.|EINZELPROZESS| WHERE |EINZELPROZESS|.|EINPROZESSART| =
? AND |EINZELPROZESS|.|EINIPADRESSE|= ? AND |EINZELPROZESS|.|EINPROZESSDAT| =
?

Das erste ? ist die Prozessart, das sind einzelne Nummern von 20000 bis 20015.
Das zweite ? ist die IP-Adresse einer Produktionsmaschine, von der die Daten
stammen.
Das dritte ? ist das Abfragedatum.

Jetzt habe ich bei allen drei Parametern die Funktion "bei verànderten
Zellwerten automatisch aktualisieren" angehakt. Das funktioniert so aber
nicht.

Wenn ich die Parameter, die sich auf dem gleichen Datenblatt wie die
Datentabelle befinden àndere, wird nichts neu berechnet. Ich muss zuerst das
Icon für "Alles aktualisieren" drücken. Dann wird neu recherchiert und
aktualisiert.

Was mache ich falsch?

Grüße
Michael Mahle

Ähnliche fragen