Bekomme W7 PC nicht in (Samba) Domain

03/06/2011 - 16:01 von Oliver Doll | Report spam
Grr, ich habe schon seit làngerem zwei W7 PCs in der Domàne drin, aber
seit gestern mühe ich mich vergeblich einen weiteren hinzuzufügen.

Samba-Version 3.5.6

Laut Samba-Wiki [1] müssen ja nur die beiden Keys

HKLM\System\CCS\Services\LanmanWorkstation\Parameters
DWORD DomainCompatibilityMode = 1
DWORD DNSNameResolutionRequired = 0

gesetzt werden (erledigt und rebootet!)

Laut C:\Windows\debug\NetSetup.log scheitere ich aber immer wegen
fehlenden Schreibrechten auf dem DC?!?

NetpDoDomainJoin
NetpMachineValidToJoin: 'MYPC'
OS Version: 6.1
Build number: 7601 (7601.win7sp1_gdr.110408-1631)
ServicePack: Service Pack 1
SKU: Windows 7 Professional
NetpDomainJoinLicensingCheck: ulLicenseValue=1, Status: 0x0
NetpGetLsaPrimaryDomain: status: 0x0
NetpMachineValidToJoin: status: 0x0
NetpJoinDomain
Machine: MYPC
Domain: MYDOMAIN
MachineAccountOU: (NULL)
Account: MYDOMAINoot
Options: 0x27
NetpLoadParameters: loading registry parameters...
NetpLoadParameters: status: DNSNameResolutionRequired set to '0'
NetpLoadParameters: status: DomainCompatibilityMode set to '1'
NetpLoadParameters: status: 0x0
NetpValidateName: checking to see if 'MYDOMAIN' is valid as type 3
name
NetpCheckDomainNameIsValid [ Exists ] for 'MYDOMAIN' returned 0x0
NetpValidateName: name 'MYDOMAIN' is valid for type 3
NetpDsGetDcName: trying to find DC in domain 'MYDOMAIN', flags 0x1020
NetpLoadParameters: loading registry parameters...
NetpLoadParameters: status: DNSNameResolutionRequired set to '0'
NetpLoadParameters: status: DomainCompatibilityMode set o '1'
NetpLoadParameters: status: 0x0
NetpDsGetDcName: found DC '\\MYDC' in the specified domain
NetpJoinDomainOnDs: NetpDsGetDcName returned: 0x0
NetpJoinDomain: status of connecting to dc '\\MYDC': 0x0
NetpProvisionComputerAccount:
lpDomain: MYDOMAIN
lpMachineName: MYPC
lpMachineAccountOU: (NULL)
lpDcName: MYDC
lpDnsHostName: (NULL)
lpMachinePassword: (null)
lpAccount: MYDOMAINoot
lpPassword: (non-null)
dwJoinOptions: 0x27
dwOptions: 0x40000003
NetpLdapBind: ldap_bind failed on MYDC: 81: Server herunterfefahren
NetpGetLsaPrimaryDomain: DNS Domain policy not supported, falling back
to Primay Domain
NetpGetLsaPrimaryDomain: status: 0x0
NetpCreateComputerObjectInDs: DC passed '\\MYDC' doesn't have writable
DS 0x101
NetpProvisionComputerAccount: LDAP creation failed: 0x32
NetpProvisionComputerAccount: Retrying downlevel per options
NetpManageMachineAccountWithSid: NetUserAdd on 'MYDC' for 'MYPC$'
failed: 0x8ad
NetpProvisionComputerAccount: retry status of creating account: 0xa89
NetpJoinDomainOnDs: Function exits with status of: 0xa89
NetpJoinDomainOnDs: status of disconnecting from '\\MYDC': 0x0
NetpDoDomainJoin: status: 0xa89

Sieht eher nach Samba, als nach einem W7 Problem aus?

Was könnte das sein?
DuG
Oliver

PS: verwende kein LDAP

[1] http://wiki.samba.org/index.php/Windows7
 

Lesen sie die antworten

#1 Oliver Doll
03/06/2011 - 17:41 | Warnen spam
On Fri, 03 Jun 2011 16:01:36 +0200, Oliver Doll wrote:
Grr, ich habe schon seit làngerem zwei W7 PCs in der Domàne drin, aber
seit gestern mühe ich mich vergeblich einen weiteren hinzuzufügen.



PS: könnte dies mit meiner Änderung vom 26.4.2011 zusammen hàngen?
news:
DuG
Oliver

Ähnliche fragen