BEREICH.VERSCHIEBEN dynamisch - "Garantieproblem"

09/03/2017 - 18:43 von Jörg Eisenträger | Report spam
Hallo NG,

in Spalte A steht der erste Tag jedes Monats aufsteigend vom 01. Januar
2001 bis zum heutigen Monat, formatiert als MMM JJJJ.
In Spalte B steht die Anzahl der im jeweiligen Monat produzierten
Geràte.
In Spalte C soll angegeben werden, wieviel produzierte Geràte im
jeweiligen Monat gemàß Spalte A, noch unter Garantie fallen bei
gegebener Garantiezeit in Monaten.
Eine Grafik zeigt die Werte in Spalte C in Abhàngigkeit von Spalte A.

Bis einschl. Oktober 2016 war die Garantiezeit konstant und betrug 36
Monate. Die Anzahl der in einem bestimmten Monat unter Garantie
fallenden Geràte wurde bis dahin mit folgender Formel berechnet, z. B.
für Zeile 94:

C94 =SUMME(BEREICH.VERSCHIEBEN(B94;-35;0;36;1))

Seit November 2016 betràgt die Garantiezeit nur noch 24 Monate. In einem
bestimmten Monat ab November 2016 ist die Anzahl der unter Garantie
fallenden Geràte also gleich der Summe aus den Geràten mit 36 Monaten
Garantie (produziert vor Nov. 2016) und aus den Geràten mit 24 Monaten
Garantie (produziert seit Nov. 2016).

Die Grafik über den gesamten Zeitraum wird weiterhin benötigt.

Gesucht ist eine Formel für Spalte C, die für jeden Monat die Anzahl der
unter Garantie fallenden Geràte berechnet und dabei die Änderung der
Garantiedauer zum November 2016 berücksichtigt.

Eine Idee?

Viele Grüße
Jörg
 

Lesen sie die antworten

#1 Claus Busch
09/03/2017 - 19:17 | Warnen spam
Hallo Jörg,

Am Thu, 09 Mar 2017 18:43:07 +0100 schrieb Jörg Eisentràger:

Bis einschl. Oktober 2016 war die Garantiezeit konstant und betrug 36
Monate. Die Anzahl der in einem bestimmten Monat unter Garantie
fallenden Geràte wurde bis dahin mit folgender Formel berechnet, z. B.
für Zeile 94:

C94 =SUMME(BEREICH.VERSCHIEBEN(B94;-35;0;36;1))



ich weiß nicht, ob ich dich richtig verstehe. Angenommen, deine Daten
beginnen in A2, dann kannst du doch keinen Versatz von -35 haben.
Außerdem hast du im ersten Monat deiner Daten doch nur die Anzahl der
Geràte dieses Monats.
Probiere mal in Zeile 2:
=SUMME(BEREICH.VERSCHIEBEN(B2;-MIN(WENN(A2<DATUM(2016;11;1);35;23);ANZAHL($A$2:A2)-1);;MIN(ANZAHL($A$2:A2);WENN(A2<DATUM(2016;11;1);36;24))))

Sollte dies nicht zum gewünschten Ergebnis führen, beschreibe mal etwas
nàher.


Mit freundlichen Grüßen
Claus
Windows10
Office 2016

Ähnliche fragen