bereiche flexibel definieren? Hilfe :)

11/02/2008 - 10:01 von Alina | Report spam
Hallo Zusammen!
Ich habe Schwierigkeiten, Bereiche flexibel einzurichten. Gibt es eine
Funktion in Excel, die besagt, dass ein Bereich immer dann anfàngt, wenn eine
"0"(Null) gelesen wird, und der Bereich immer dann Endet, wenn wieder eine
"0"(Null) gelesen wird. Mein Ziel ist es, die Anzahl der "1" (oder
Wahr)-Eintràge innerhalb eines Bereiches zu erhalten, ohne dass ich den
Bereich immer neu definieren muss.
Beispiel:

Eingabeseite in zwei Spalten:

FALSCH 0
WAHR 1
WAHR 1
WAHR 1
FALSCH 0
WAHR 1
WAHR 1
WAHR 1
WAHR 1
FALSCH 0
WAHR 1
WAHR 1
WAHR 1
FALSCH 0
WAHR 1
WAHR 1
WAHR 1
FALSCH 0
WAHR 1
WAHR 1
FALSCH 0
...
Ausgabe müsste lauten: (in Spalte oder Zeile, egal): {3;4;3;3;2...)
Bin Dankbar für jede Art von Anregungen. Gruß! Alina
 

Lesen sie die antworten

#1 Frank Willberger
11/02/2008 - 10:20 | Warnen spam
Moin, Moin!

Hallo Zusammen!
Ich habe Schwierigkeiten, Bereiche flexibel einzurichten. Gibt es eine
Funktion in Excel, die besagt, dass ein Bereich immer dann anfàngt, wenn eine
"0"(Null) gelesen wird, und der Bereich immer dann Endet, wenn wieder eine
"0"(Null) gelesen wird. Mein Ziel ist es, die Anzahl der "1" (oder
Wahr)-Eintràge innerhalb eines Bereiches zu erhalten, ohne dass ich den
Bereich immer neu definieren muss.
Beispiel:

Eingabeseite in zwei Spalten:

FALSCH 0
WAHR 1
WAHR 1
WAHR 1
FALSCH 0
WAHR 1
WAHR 1
WAHR 1
WAHR 1
FALSCH 0
WAHR 1
WAHR 1
WAHR 1
FALSCH 0
WAHR 1
WAHR 1
WAHR 1
FALSCH 0
WAHR 1
WAHR 1
FALSCH 0

Ausgabe müsste lauten: (in Spalte oder Zeile, egal): {3;4;3;3;2...)



Bau Dir eine Spalte C mit C1 gleich 1 (oder einen anderen Startwert) und
C2 ... mit =WENN(B2=0;C1+1;C1). Damit erreichst Du, daß bei jeder Null
der Wert hochgezàhlt wird. Zàhlst Du jetzt die Werte in C aus (mit z.B.
ZÄHLENWENN) und ziehst 1 ab, erhàltst Du Dein Ergebnis.

hth

Frank

Ähnliche fragen