Bericht ohne Daten Ac07; XP

26/05/2009 - 16:47 von Heinz Müller | Report spam
Hallo NG,
Ich habe ein Problem mit Berichten, die auf Grund fehlender Daten, mit dem
Ereignis <Bei ohne Daten> beendet wird:

Private Sub Report_NoData(Cancel As Integer)
MsgBox "keine Daten zur Ausgabe vorhanden!", vbInformation, "Abbruch"
Cancel = True
End Sub

Dies funktioniert auch, nur kann ich daraufhin nicht mehr auf den
Navigationsbereich zugreifen, im Eigenschaftsblatt (falls der Bericht vorher
im Entwurfsmodus geöffnet wurde) sind keine Änderungen mehr möglich und der
gesamte Bildschirm regiert so, als hàtte ich noch ein (unsichtbares)
Dialogfeld geöffnet (dh. mit beep). Der Bericht wird nicht im PopUp-Modus
geöffnet!

Wer weiß woran das liegen könnte?

Gruß aus München
Heinz Müller
 

Lesen sie die antworten

#1 Karl Donaubauer
26/05/2009 - 20:48 | Warnen spam
Heinz Müller wrote:
Ich habe ein Problem mit Berichten, die auf Grund fehlender Daten,
mit dem Ereignis <Bei ohne Daten> beendet wird:

Private Sub Report_NoData(Cancel As Integer)
MsgBox "keine Daten zur Ausgabe vorhanden!", vbInformation, "Abbruch"
Cancel = True
End Sub

Dies funktioniert auch, nur kann ich daraufhin nicht mehr auf den
Navigationsbereich zugreifen, im Eigenschaftsblatt (falls der Bericht
vorher im Entwurfsmodus geöffnet wurde) sind keine Änderungen mehr
möglich und der gesamte Bildschirm regiert so, als hàtte ich noch ein
(unsichtbares) Dialogfeld geöffnet (dh. mit beep). Der Bericht wird
nicht im PopUp-Modus geöffnet!

Wer weiß woran das liegen könnte?



Bei mir verhàlt sich A07 (SP1) diesbez. wie die Vorgànger.
Welches SP hast du installiert?

Wie öffnest du den Bericht?
Aus dem Navibereich heraus oder per Code?
Falls per Code, dann müsstest du einen Abbruch-Fehler bekommen,
wie in www.donkarl.com?FAQ5.8 beschrieben.

Macht es einen Unterschied, wie du den Bericht öffnest?

HTH
Karl
********* Ich beantworte keine Access-Fragen per Email. *********
Access-FAQ: http://www.donkarl.com

Ähnliche fragen