Bezug auf Zelle festhalten, verschiebt sich trotz $

17/02/2010 - 12:12 von Thomas Metzner | Report spam
Hallo NG,
ich moechte in einer Tabelle1
Beispiel:
Datum ArbeitsSTD
10.02.2010 15
15.02.2010 20
15.03.2010 30,5

Diese Tabelle wird eingefuegt, Zellen kopiert, geloescht und sortiert
allerdings bleibt die Struktur fest und die annahme das es max 100 Eintraege
gibt.

auf einem 2ten Tabellenblatt mochte ich jetzt eine Jahres Statistic machen

Monat STDSumme
02.2010 35
03.2010 30,5
04.2010 0
05.2010 0
06.2010 0
07.2010 0
08.2010 0
09.2010 0
10.2010 0
11.2010 0
12.2010 0
01.2011 0

65,5
Um das nicht Statisch pflegen zu muessen lese ich auf der Statistictabelle
den min Datum aus der Daten Tabelle und zaehle dann 12 mal 1 monat hoch->
das geht
In der STDSumme habe ich folgende Formel:
=SUMMENPRODUKT((Tabelle1!$A$2:$A$100>¢)*(Tabelle1!$A$2:$A$100<A3)*Tabelle1!$B$2:$B$100)
das geht auch, allerdings wenn in Tabelle1 in der 2 Zeile Zellen eingefuegt
werden verschiebt sich der Bezug, obwohl er mit $ maskiert ist:
=SUMMENPRODUKT((Tabelle1!$A$3:$A$101>¢)*(Tabelle1!$A$3:$A$101<A3)*Tabelle1!$B$3:$B$101)

Wie kann ich das sonst verhindern, der Bezug soll A2:A100 bleiben?
Vielen Dank fuer Eure Hilfe
Gruss Thomas
 

Lesen sie die antworten

#1 Claus Busch
17/02/2010 - 12:21 | Warnen spam
Hallo Thomas,

Am Wed, 17 Feb 2010 12:12:15 +0100 schrieb Thomas Metzner:

ich moechte in einer Tabelle1
Beispiel:
Datum ArbeitsSTD
10.02.2010 15
15.02.2010 20
15.03.2010 30,5

Diese Tabelle wird eingefuegt, Zellen kopiert, geloescht und sortiert
allerdings bleibt die Struktur fest und die annahme das es max 100 Eintraege
gibt.

auf einem 2ten Tabellenblatt mochte ich jetzt eine Jahres Statistic machen



Vorschlag meinerseits:
Erstelle für deine Tabelle1 einen dynamischen Bereichsnamen und mit diesem
Namen als Quell eine Pivot-Tabelle. Gruppiere die Pivot-Tabelle nach
Monaten.


Mit freundlichen Grüssen
Claus Busch
Win XP PRof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen