Bind reagiert nicht auf reverse IPv6 Zonen?

17/01/2008 - 22:38 von Nikolaus Hammler | Report spam
Hi,

Ich hab einen Nameserver, dem ich jetzt neben verschiedenen "normalen"
Domains die Reversezone für mein IPv6 Subnet hinzugefügt habe:

d.c.3.0.8.b.7.0.1.0.0.2.ip6.arpa.

Bind will mir das aber einfach nicht auflösen und ich check nicht wieso!

Meine named.conf beinhaltet nun:

zone "nobaq.net." {
type master;
file "/etc/bind/db.nobaq.net";
};

zone "d.c.3.0.8.b.7.0.1.0.0.2.ip6.arpa." {
type master;
file "/etc/bind/db.d.c.3.0.8.b.7.0.1.0.0.2.ip6.arpa";
};

[...]

logging {
channel queries-log { file "/tmp/queries.log"; };
category queries { queries-log; };
};

Das Auflösen von nobaq.net funktioniert ohne Probleme wie erwartet (ging
ja auch schon immer):

# dig @192.168.200.113 nobaq.net. TXT

[...]

;; ANSWER SECTION:
nobaq.net. 3600 IN TXT "Test"

[...]


Wider erwarten funktioniert aber die Auflösung meiner neuen IPv6 Zone nicht:

# dig @192.168.200.113 d.c.3.0.8.b.7.0.1.0.0.2.ip6.arpa. TXT

; <<>> DiG 9.3.4 <<>> @192.168.200.113 d.c.3.0.8.b.7.0.1.0.0.2.ip6.arpa. TXT
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 19741
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;d.c.3.0.8.b.7.0.1.0.0.2.ip6.arpa. IN TXT

;; Query time: 7 msec
;; SERVER: 192.168.200.113#53(192.168.200.113)
;; WHEN: Thu Jan 17 22:31:39 2008
;; MSG SIZE rcvd: 50

Er sagt mir immer: "refused".

Auch im queries.log, das mir der bind brav erstellt scheint nur die
erste Abfrage auf.

Und das witzige ist weiters, dass die Zonentransfers ohne Probleme
funktionieren.
Im Internet hab ich auch nix dazu gefunden, dass Bind (9.3.4, Debian
etch) speziell konfiguriert werden müsste...

Weiss jemand an was das liegen könnte?

lg,
Niki
 

Lesen sie die antworten

#1 Juergen P. Meier
18/01/2008 - 07:50 | Warnen spam
Nikolaus Hammler :
; <<>> DiG 9.3.4 <<>> @192.168.200.113 d.c.3.0.8.b.7.0.1.0.0.2.ip6.arpa. TXT
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 19741
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

Auch im queries.log, das mir der bind brav erstellt scheint nur die
erste Abfrage auf.

Und das witzige ist weiters, dass die Zonentransfers ohne Probleme
funktionieren.
Im Internet hab ich auch nix dazu gefunden, dass Bind (9.3.4, Debian
etch) speziell konfiguriert werden müsste...

Weiss jemand an was das liegen könnte?



Was steht im options-Teil deiner named.conf?

Juergen
Juergen P. Meier - "This World is about to be Destroyed!"
end
If you think technology can solve your problems you don't understand
technology and you don't understand your problems. (Bruce Schneier)

Ähnliche fragen