Bizarres Problem: Nach einiger Zeit geht AltGr nicht mehr

13/05/2010 - 18:12 von Johannes Bauer | Report spam
Hallo Gruppe,

habe momentan ein überaus bizarres Problem mit meinem WM Gnome 2.28 auf
Gentoo: Einige Zeit nach dem Login per gdm geht AltGr nicht mehr, d.h.
etwa 5-10 Minuten nachdem ich mich eingeloggt habe und arbeite bringen
Tastendrücke auf "@" oder "\" nurnoch "q" oder "ß" zum Vorschein. Das
passiert nicht nur im gnome-terminal, sondern auch in allen anderen
Applikationen (Firefox, Thunderbird, OpenOffice, etc) und ist *extrem*
nervig. Vorallem Programmieren kann man damit total vergessen, wenn ich
keine "{" o.à. mehr machen kann.

Abhilfe schafft ausloggen und wieder einloggen, ist aber wirklich keine
Lösung.

Auch wenn das passiert, löst AltGr trotzdem noch im xev ganz regulàre
Events aus.

Bevor das Problem auftritt, Druck auf AltGr:

KeyPress event, serial 33, synthetic NO, window 0x3000001,
root 0x142, subw 0x0, time 153940638, (-272,391), root:(1343,503),
state 0x0, keycode 113 (keysym 0xfe03, ISO_Level3_Shift),
same_screen YES,
XLookupString gives 0 bytes:
XmbLookupString gives 0 bytes:
XFilterEvent returns: False

Bevor das Problem auftritt, Druck auf "@" (AltGr + Q):

KeyPress event, serial 33, synthetic NO, window 0x3000001,
root 0x142, subw 0x0, time 153987826, (1204,408), root:(1253,486),
state 0x80, keycode 24 (keysym 0x40, at), same_screen YES,
XLookupString gives 1 bytes: (40) "@"
XmbLookupString gives 1 bytes: (40) "@"
XFilterEvent returns: False

Wenn das Problem auftritt, druck auf AltGr:

KeyPress event, serial 33, synthetic NO, window 0x2e00001,
root 0x142, subw 0x0, time 154636011, (601,848), root:(2216,960),
state 0x0, keycode 113 (keysym 0xfe03, ISO_Level3_Shift),
same_screen YES,
XLookupString gives 0 bytes:
XmbLookupString gives 0 bytes:
XFilterEvent returns: False

Wenn das Problem auftritt, Druck auf AltGr + Q:

KeyPress event, serial 33, synthetic NO, window 0x2e00001,
root 0x142, subw 0x0, time 154719328, (494,377), root:(2109,489),
state 0x0, keycode 113 (keysym 0xfe03, ISO_Level3_Shift),
same_screen YES,
XLookupString gives 0 bytes:
XmbLookupString gives 0 bytes:
XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x2e00001,
root 0x142, subw 0x0, time 154719679, (494,377), root:(2109,489),
state 0x80, keycode 24 (keysym 0x71, q), same_screen YES,
XLookupString gives 1 bytes: (71) "q"
XmbLookupString gives 1 bytes: (71) "q"
XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x2e00001,
root 0x142, subw 0x0, time 154719785, (494,377), root:(2109,489),
state 0x80, keycode 24 (keysym 0x71, q), same_screen YES,
XLookupString gives 1 bytes: (71) "q"
XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x2e00001,
root 0x142, subw 0x0, time 154720126, (494,377), root:(2109,489),
state 0x80, keycode 113 (keysym 0xfe03, ISO_Level3_Shift),
same_screen YES,
XLookupString gives 0 bytes:
XFilterEvent returns: False

Hat jemand eine Idee was das sein könnte oder wo ich nachfragen kann?
Das treibt mich in den Wahnsinn!

Viele Grüße,
Johannes



Wo hattest Du das Beben nochmal GENAU vorhergesagt?


Zumindest nicht öffentlich!


Ah, der neueste und bis heute genialste Streich unsere großen
Kosmologen: Die Geheim-Vorhersage.
- Karl Kaos über Rüdiger Thomas in dsa <hidbv3$om2$1@speranza.aioe.org>
 

Lesen sie die antworten

#1 Arno Wald
15/05/2010 - 20:31 | Warnen spam
Johannes Bauer wrote:

Hat jemand eine Idee was das sein könnte oder wo ich nachfragen kann?



Wird ggf. im Hintergrund nach einigen Minuten ein KDE-Programm gestartet,
wodurch auch irgendwelche KDE-settings aktiv werden, wo dann ggf. ein
falsches Keyboard eingestellt ist? Oder irgendetwas in dieser Art? Ggf. auch
mit xfce statt KDE oder so?

Findet sich nichts in den Logfiles unter /var/log/ oder auch "~/.xsession-
errors"?

Ähnliche fragen