BLUEZ auf FLI4L mit MDA compact III verbinden

14/01/2008 - 01:36 von Marcia Schmid | Report spam
Hallo NG,

Nach der Installation von Bluez habe ich Probleme mit meinem MDA Compact
III Kontakt zum Router zu bekommen. Laut Bootlog gab es keine Probleme
beim Start.
Ein Pearing funktioniert. Problem ist aber, das die zur Verfügung
gestellten Dienste (PAN) nicht auf dem Pocket-PC angezeigt werden. Das
Feld bleibt auch beim erneuten Pearing leer!
Ich habe für die folgenden Daten vergleichsweise einen MDA Vario III
herangezogen (wegen WLAN). Die Bluetooth Werte beim Vario III und
Compact III sind identisch (leider).

Ping mit vxutil:

per WLAN Ping auf 192.168.44.3 (ungültige Adresse)
192.168.44.3 *Request time out
192.168.44.3 *Request time out
192.168.44.3 *Request time out
192.168.44.3 *Request time out
Total 4, Good 0, Bad 4

per WLAN Ping auf 192.168.44.4 (gültige Adresse)
192.168.44.4 RTT= 9 ms sz= 32 TTLd
192.168.44.4 RTT= 8 ms sz= 32 TTLd
192.168.44.4 RTT= 7 ms sz= 32 TTLd
192.168.44.4 RTT= 9 ms sz= 32 TTLd
Total 4, Good 4, Bad 0

per Bluetooth Ping auf 192.168.44.3 (ungültige Adresse)
0.0.0.0 RTT= 0 ms sz= 5 TTL2
0.0.0.0 RTT= 0 ms sz= 5 TTL2
0.0.0.0 RTT= 0 ms sz= 5 TTL2
0.0.0.0 RTT= 0 ms sz= 5 TTL2
Total 4, Good 4, Bad 0

per Bluetooth auf 192.168.44.4 (gültige Adresse)
0.0.0.0 RTT= 0 ms sz= 5 TTL2
0.0.0.0 RTT= 0 ms sz= 5 TTL2
0.0.0.0 RTT= 0 ms sz= 5 TTL2
0.0.0.0 RTT= 0 ms sz= 5 TTL2
Total 4, Good 4, Bad 0

Um der Frage gleich vorzubeugen, nein ich habe mich nicht vertippt bei
Bluetooth erhalte ich immer das gleiche Ergebnis. Ping auf 127.0.0.1
funktioniert. Ein Ping auf die fest vergebene IP des BT-PAN des
Pocket-PC nicht!

Ich habe das eingetrage Pearing extra vorher gelöscht und
nochmal neu durchgeführt. Nur um sicher zu gehen das es nicht daran lag!

vxutil info (Auszug)
TNETW12511 - IEEE 802.11b/g Compatible Wi-Fi Adapter
IP Adress: 192.168.44.44
Subnet Mask : 255.255.255.0
Default Gateway: 192.168.44.4
Primary DNS: 192.168.44.4
Secondary DNS:
Primary WINS:
Secondary WINS:
DHCP SERVER:

BTPAN! - Bluetooth PAN Driver
IP Adress: 192.168.44.45
Subnet Mask : 255.255.255.0
Default Gateway: 192.168.44.4
Primary DNS: 192.168.44.4
Secondary DNS:
Primary WINS:
Secondary WINS:
DHCP SERVER:

Meine Vermutung ist das es an BLUEZ bzw. der daran folgenden LAN
Konfiguration liegt.

Die Einstellungen in der advanced_networking.txt
BRIDGE_DEV_1_STP='no'
BRIDGE_DEV_1_FORWARD_DELAY='0'
funktionieren so nicht. Zunàchst wurde

wrong value of variable BRIDGE_DEV_1_FORWARD_DELAY:'0' (Forward Delay
must be a value between 4 and 30.)

bemàngelt dies habe ich probeweise in der check/advanced_networking.rxp
entsprechend angepasst. Darauf gab es die Meldung

Error: If BRIDGE_DEV_1_STP is set to 'no' od undefined you can't specify
BRIDGE_DEV_1_FORWARD_DELAY, please remove this option!

ich habe dann verschiedene mögliche Kombis ausprobiert STP=YES bzw.
DELAY=4. Änderte an der Verbindung FLI4L -> Pocket-PC nichts. Bin mit
meinen zugegebener Massen geringen Netzwerkkenntnissen am Ende. Wo muss
ich ansetzen um dem Fehler auf die Spur zu kommen? Was kann ich zum
Testen ausser vxutil noch benutzen, bzw. wie schaut es auf FLI4L Seite
mit Testmöglichkeiten aus?

Gruß Marcia
 

Lesen sie die antworten

#1 Marcia Schmid
17/01/2008 - 20:42 | Warnen spam
Hallo,

hat niemand seinen Pocket PC per Bluetooth (PAN) mit Linux verbunden?

Gruß Marcia

Ähnliche fragen