Booten eines verschlüsselten Systems

07/01/2015 - 12:20 von Christian Knoke | Report spam
Hallo,

ich habe mit dem von einer Debian-Live CD gestarteten Debian-Installer ein
Wheezy System installiert, mit Wurzelverzeichnis auf einer verschlüsselten
Partition und dem /boot/ Verzeichnis auf einer unverschlüsselten
Partition.

Die Installation lief fehlerfrei durch.

Sie làsst sich aber nicht booten.

Grub làdt den Kernel und die Initrd, danach ist Schluss. Zu dem Zeitpunkt
sollte wohl die Passphrase abgefragt und das root device gemountet werden.

Leider kann ich Grub und Initrd nun auch nicht vom laufenden System aus
reparieren/debuggen, da dass System nicht started. Oder komme ich da "von
Hand" hin, mit der grub commandline vielleicht?

In die Initrd habe ich mal reingeguckt, da sind Teile der Live CD drin, die
da nicht unbedingt hingehören. Mehr kann ich nicht erkennen.

Wo könnte der Fehler liegen?

Gruß
Christian

Christian Knoke * * * http://cknoke.de
* * * * * * * * * Ceterum censeo Microsoft esse dividendum.


Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/20150107111258.GA5479@localhost.localdomain
 

Lesen sie die antworten

#1 Stefan Klein
07/01/2015 - 12:50 | Warnen spam

Am 7. Januar 2015 um 12:12 schrieb Christian Knoke :


Hallo,

ich habe mit dem von einer Debian-Live CD gestarteten Debian-Installer ein
Wheezy System installiert, mit Wurzelverzeichnis auf einer verschlà¼sselten
Partition und dem /boot/ Verzeichnis auf einer unverschlà¼sselten
Partition.

Die Installation lief fehlerfrei durch.

Sie là¤sst sich aber nicht booten.

Grub là¤dt den Kernel und die Initrd, danach ist Schluss. Zu dem Zeitpunkt
sollte wohl die Passphrase abgefragt und das root device gemountet werden.





Là¤ufst du in den modus das du eine Shell (in der initrd) bekommst?
Wenn ja, ist "cryptsetup" verfà¼gbar?

Grà¼àŸe,
Stefan


<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">Am 7. Januar 2015 um 12:12 schrieb Christian Knoke <span dir="ltr">&lt;<a href="mailto:" target="_blank"></a>&gt;</span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
Hallo,<br>
<br>
ich habe mit dem von einer Debian-Live CD gestarteten Debian-Installer ein<br>
Wheezy System installiert, mit Wurzelverzeichnis auf einer verschlà¼sselten<br>
Partition und dem /boot/ Verzeichnis auf einer unverschlà¼sselten<br>
Partition.<br>
<br>
Die Installation lief fehlerfrei durch.<br>
<br>
Sie là¤sst sich aber nicht booten.<br>
<br>
Grub là¤dt den Kernel und die Initrd, danach ist Schluss. Zu dem Zeitpunkt<br>
sollte wohl die Passphrase abgefragt und das root device gemountet werden.<br></blockquote><div><br><br></div><div>Là¤ufst du in den modus das du eine Shell (in der initrd) bekommst?<br></div><div>Wenn ja, ist &quot;cryptsetup&quot; verfà¼gbar?<br></div><div><br></div></div>Grà¼àŸe,<br></div><div class="gmail_extra">Stefan<br></div></div>



Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/CAA=cwqE6F...SM0XaXsy++

Ähnliche fragen