Bootproblem mit Jessie

09/03/2016 - 19:10 von Siegfrid Brandst | Report spam
Hallo,
nach einem Update von Wheezy auf Jessie gestern Nacht habe ich nun folgende
Probleme. Sobald ich Grub automatisch die erste Zeile starten lasse bleibt der
Vorgang hàngen, sieht aus wie ein Eintrag von dmesg, Diese Seite erneuert sich
dann immer wieder nach ca. einer Minute.
Wenn ich aber mit der zweiten Zeile in Grub starte (sysvinit) dann làuft es
durch.
.
Wie findet man raus was der Grund ist, oder kann man die Zeile mit dem Eintrag
(sysvinit) als erste setzen. Besser wàre wohl den Fehler zu finden.

Mit # journalctl --since "20 min ago” erhalte ich das es keine Journale gibt,
auch nicht wenn ich die Minuten àndere. Auch bei anderen versuchen wie z.B.
# journalctl -b

Dafür erhielt ich von:
$ systemctl --failed
Failed to get D-Bus connection: Unbekannter Fehler -1

Habe auch schon einen anderen Kernel als den 3.16. versucht, den 4.3. damit
passiert das selbe und dann bleibt der auch noch im KDE Startbildschirm ca. 10
Minuten hàngen, danach gibt es einen schwarzen Bildschirm mit Mauscurser und
man kann auch nicht mehr auf eine Konsole gehen um abzudrehen. Alles nicht so
gut.


Liebe Grüße
Sigi
 

Lesen sie die antworten

#1 Harald Weidner
10/03/2016 - 10:00 | Warnen spam
Hallo,

On Wed, Mar 09, 2016 at 05:46:53PM +0000, Siegfrid Brandstàtter wrote:

nach einem Update von Wheezy auf Jessie gestern Nacht habe ich nun folgende
Probleme. Sobald ich Grub automatisch die erste Zeile starten lasse bleibt der
Vorgang hàngen, sieht aus wie ein Eintrag von dmesg, Diese Seite erneuert sich
dann immer wieder nach ca. einer Minute.
Wenn ich aber mit der zweiten Zeile in Grub starte (sysvinit) dann làuft es
durch.
.
Wie findet man raus was der Grund ist, oder kann man die Zeile mit dem Eintrag
(sysvinit) als erste setzen. Besser wàre wohl den Fehler zu finden.



Das hört sich für mich so an, als startet der Rechner korrekt mt sysvinit, aber
der Bootvorgang scheitert mit systemd als Init-System.

In diesem Fall kannst du sysvinit als Init-System erzwingen:

# aptitude -y install sysvinit-core

Dafür erhielt ich von:
$ systemctl --failed
Failed to get D-Bus connection: Unbekannter Fehler -1



Das ist normal und liegt daran, dass sysvinit und nicht systemd als Init-System
làuft. systemctl versucht, per dbus mit systemd zu sprechen.

Was hier genau schief làuft, kann man mit so wenig Informationen nicht sagen.
Wenn es dich interessiert, solltest du in den Logs unter /var/log stöbern.
Um den Bootvorgang ausführlicher zu machen, kannst du den Kernel-Parameter
"quiet" entfernen und wahlweise "verbose", "debug" und/oder "ignore_loglevel"
setzen.

Ansonsten: wenn du nicht gerade Gnome3 benutzen willst, gibt es eigentlich
keinen Grund, systemd zu vermissen. Vielleicht wird das in Debian 9 halbwegs
brauchbar.

Gruß, Harald

Ähnliche fragen