Bridge IPv6 stirbt weg, IPv4 rennt weiter, warum, wie korrigieren?

10/10/2014 - 17:20 von Lars Schimmer | Report spam
Hash: SHA1

Hallo!

Ich habe einen Server als KVM Host mit IPv4 und IPv6 Connectivity und
diversen VMs, die auch IPv4 und IPv6 bekommen sollen.
Dazu habe ich eine Bridge auf dem Host eingerichtet:

auto br0
iface br0 inet static
address 11.77.11.22
netmask 255.255.255.0
broadcast 11.77.11.255
gateway 11.77.11.1
bridge_ports eth0

iface br0 inet6 static
address 2a01:11:12:12::1:5
gatway 2a01:11:12:12::1
pre-down exit 1

(p.s. IP Adressen etwas anonymisiert)

Soweit rennt das nach einem Reboot problemfrei, Host und VMs bekommen
IPv4 und IPv6 connectivity. Jeweils mit fixer IP, kein DHCP oder
àhnliches.
ABER nach ein wenig Zeit (mal 30 Tagen, mal 2h) ist IPv6 tod -
connect: Network is unreachable gibt ein ping6 raus.
Und da stehe ich auf dem Schlauch. Warum ist dann auf einmal IPv6 weg,
wàhrend IPv4 problemfrei weiter tut?
Wie bekomme ich IPv6 wieder aktiv?
Ein /etc/init.d/network restart gibt zwar IPv6 udn IPv4 Connectivity
auf dem Host, aber die VMs haben danach kein Netzwerk mehr, da hilft
nur reboot des Hosts. Total blöde.
Weiß einer, wie ich IPv6 da wieder reaktivieren kann?

Danke.

MfG,
Lars Schimmer
TU Graz, Institut für ComputerGraphik & WissensVisualisierung
Tel: +43 316 873-5405 E-Mail: l.schimmer@cgv.tugraz.at
Fax: +43 316 873-5402 PGP-Key-ID: 0x4A9B1723


Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/5437EEE8.30707@cgv.tugraz.at
 

Lesen sie die antworten

#1 Paul Muster
10/10/2014 - 17:50 | Warnen spam
On 10.10.2014 16:36, Lars Schimmer wrote:

ABER nach ein wenig Zeit (mal 30 Tagen, mal 2h) ist IPv6 tod -
connect: Network is unreachable gibt ein ping6 raus.
Und da stehe ich auf dem Schlauch. Warum ist dann auf einmal IPv6 weg,
wàhrend IPv4 problemfrei weiter tut?



Wie sehen "brctl show" und "brctl showstp <bridge>" normalerweise und
wie im Fehlerfall aus? Ist da irgendwas komisch?

Wie bekomme ich IPv6 wieder aktiv?
Ein /etc/init.d/network restart gibt zwar IPv6 udn IPv4 Connectivity
auf dem Host, aber die VMs haben danach kein Netzwerk mehr, da hilft
nur reboot des Hosts. Total blöde.
Weiß einer, wie ich IPv6 da wieder reaktivieren kann?



Die Interfaces von der Bridge runternehmen und wieder draufschalten? Die
Bridge löschen und neu konfigurieren?


mfG Paul



Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen