Bug in setfacl bezüglich SUID/SGID/Sticky-Bit?

05/02/2008 - 20:50 von Hauke Laging | Report spam
Moin,

ich wurde gerade darauf gestoßen, dass setfacl zwar bei -M "diese
zusàtzlichen Bits" unangetastet làsst, sie aber bei --restore
löscht. Was natürlich total für den Allerwertesten ist, weil getfacl
sie nicht auflistet. So oder so wàre ein derart inkonsistentes
Verhalten untragbar.

Ich sehe das als Bug an. Abweichende Meinungen?

hl@server:~> setfacl --version
setfacl 2.2.34

openSUSE 10.3


CU

Hauke
http://www.hauke-laging.de/ideen/
http://www.hauke-laging.de/software/
http://zeitstempel-signatur.hauke-laging.de/
Wie können 59.054.087 Leute nur so dumm sein?
 

Lesen sie die antworten

#1 Roman Racine
05/02/2008 - 21:27 | Warnen spam
Hauke Laging wrote:

ich wurde gerade darauf gestoßen, dass setfacl zwar bei -M "diese
zusàtzlichen Bits" unangetastet làsst, sie aber bei --restore
löscht. Was natürlich total für den Allerwertesten ist, weil getfacl
sie nicht auflistet. So oder so wàre ein derart inkonsistentes
Verhalten untragbar.



:/tmp$ ls -l bla
-rwsr-xr-x 1 roman roman 0 2008-02-05 21:21 bla
:/tmp$ setfacl --restore bla
:/tmp$ ls -l bla
-rwsr-xr-x 1 roman roman 0 2008-02-05 21:21 bla

:~> setfacl --version
setfacl 2.2.34



:/tmp$ setfacl --version
setfacl 2.2.42

Filesystem: XFS.

Ich sehe das als Bug an. Abweichende Meinungen?



Bei mir tritt er nicht (mehr) auf, das Verhalten ist so, wie ich es erwartet
hàtte.

Gruss

Roman°
IRC-Freenode: #usenet-friends
http://www.usenet-friends.ch.vu/

Ähnliche fragen