Calc: Addition von Zeiten

11/10/2010 - 10:13 von Bernd Zeitzen | Report spam
Hallo Wissende,
ich habe eine Tabelle, in der Zeiten berechnet (addiert, subtrahiert) werden. Die Formel sieht so
aus:=(C18-B18)+(E18-D18)+(G18-F18)+(I18-H18). Die Zellen sind so formatiert: HH:MM.
Manchmal kommt es vor, dass in einer Zelle aber ein Text steht, weil an diesem Tag nicht gearbeitet
wird, sondern ein Schultag ist. Seit Version 3.2 ist das Ergebnis der Summe #Wert, davor gab es eine
korrekte Zahl.
Hat jemand eine Idee, wie ich die Formel veràndern muss, damit OOo-Calc wieder richtig rechnet?
Schon jetzt vielen Dank.
Bernd
 

Lesen sie die antworten

#1 Regina Henschel
11/10/2010 - 13:17 | Warnen spam
Hallo Bernd,

Bernd Zeitzen schrieb:
Hallo Wissende,
ich habe eine Tabelle, in der Zeiten berechnet (addiert, subtrahiert)
werden. Die Formel sieht so
aus:=(C18-B18)+(E18-D18)+(G18-F18)+(I18-H18). Die Zellen sind so
formatiert: HH:MM.
Manchmal kommt es vor, dass in einer Zelle aber ein Text steht, weil an
diesem Tag nicht gearbeitet wird, sondern ein Schultag ist. Seit Version
3.2 ist das Ergebnis der Summe #Wert, davor gab es eine korrekte Zahl.



Ja, das Verhalten ist an die Norm angepasst worden. Ein Text wird nur
noch dann automatisch als 0 (Addition) bzw. 1 (Multiplikation) gesetzt,
wenn er innerhalb eines Zellbereichs vorkommt und von einer Funktion
ausgewertet wird, die Zellbereiche verarbeitet.

Hat jemand eine Idee, wie ich die Formel veràndern muss, damit OOo-Calc
wieder richtig rechnet?


Ab version 3.3 kannst du
=N(B1)-N(A1)+N(D1)-N(C1)+N(F1)-N(E1)+N(H1)-N(G1)
benutzen. Dort wird die Funktion N() wieder 0 liefert, falls das
Argument ein Text ist. In 3.2 geht dies leider noch nicht.

Eine Möglichkeit besteht darin, jede Differenz zu überprüfen ob sie eine
Zahl ist oder ein Fehler und im Fehlerfall auf Null setzen.
Das wird aber etwas lànglich
=WENN(ISTFEHLER(B1-A1);0;B1-A1)+WENN(ISTFEHLER(D1-C1);0;D1-C1)+WENN(ISTFEHLER(F1-E1);0;F1-E1)+WENN(ISTFEHLER(H1-G1);0;H1-G1)

Oder du benutzt statt Einzeladditionen und -subtraktionen eine Rechnung
über Bereiche
=SUMMENPRODUKT(A1:H1;{-1;1;-1;1;-1;1;-1;1})
Die Matrix {-1;1;-1;1;-1;1;-1;1} enthàlt, ob du addieren oder
subtrahieren willst.

MfG
Regina

Ähnliche fragen