[Calc] Formel gesucht

27/12/2007 - 19:00 von Micha Kuehn | Report spam
Hallo,

für eine Notenliste suche ich folgende Formel:

In einer Spalte AI stehen untereinander viele Noten. Diese wurden
automatisch berechnet. Daneben gibt es eine Spalte AJ "Abweichung", wo
davon abweichende Noten stehen können, falls ich meinen pàdagogogischen
Freiraum nutzen will und z.B. bei 2,5 nicht automatisch zur besseren
Note runden möchte.

Nun möchte ich darunter zàhlen, wie oft die Note 1, wie oft die 2 usw.
gegeben wurde. Auch den Durchschnitt will ich wissen. Dabei sollen die
Noten der Spalte AJ genommen werden, falls dort etwas steht, ansonsten
sollen die Noten aus AI genommen werden.

Ich würde gerne ohne Hilfsspalten auskommen (mit solchen Hilfspalten
könnte ich das ohne Probleme lösen).

Einen Entwurf habe ich unter
http://www.bm-kuehn.de/temp/071227-...chnung.ods gespeichert. Es
geht mir also um die Berechnung in AI35 bis AL 42.

Wie geht das korrekt? Mein Entwurf mit Matrixformeln gibt einen Fehler
und rechnet auch falsch...

Danke!

Micha
Persönliche Mails: Bitte nur als reply - und als Wurmkur werden alle
Mails > 100 KB automatisch und unbesehen gelöscht!
 

Lesen sie die antworten

#1 Siegfried Höfner
27/12/2007 - 21:09 | Warnen spam
"Micha Kuehn" schrieb:
Hallo,

für eine Notenliste suche ich folgende Formel:

In einer Spalte AI stehen untereinander viele Noten. Diese wurden
automatisch berechnet. Daneben gibt es eine Spalte AJ "Abweichung", wo
davon abweichende Noten stehen können, falls ich meinen pàdagogogischen
Freiraum nutzen will und z.B. bei 2,5 nicht automatisch zur besseren
Note runden möchte.

Nun möchte ich darunter zàhlen, wie oft die Note 1, wie oft die 2 usw.
gegeben wurde. Auch den Durchschnitt will ich wissen. Dabei sollen die
Noten der Spalte AJ genommen werden, falls dort etwas steht, ansonsten
sollen die Noten aus AI genommen werden.


[...]

Beispiel für Note 1 :
{=SUMME((AI4:AI33à6)*(ISTLEER(AJ4:AJ33)))+ZÄHLENWENN(AJ4:AJ33;C36)}

Bei weiteren Fragen nochmal melden.

Gruß Siegfried

Ähnliche fragen