Calc. Probleme mit Formel

12/04/2009 - 12:57 von Roland Leuschner | Report spam
Hallo an alle und frohe Ostern!
Wer kann helfen?
Ich soll eine Formel erstellen, die Folgendes ausrechnet:

Gegeben ist eine Tabelle. In der Spalte C stehen Zahlen. In der Spalte D
stehen mal Zahlen, mal Text, in willkürlicher Reihenfolge.

In z.B. C70 soll nun die Summe aus C stehen; es sollen aber nur die
Zahlen aus C berücksichtigt werden, bei denen in der gleichen Reihe
(z.B. Reihe 7) in D eine Zahl steht. Steht hingegen in D Text, soll die
Zahl in C nicht berücksichtigt werden.

Ein Beispiel:
C3 = 6; D3= 5,2
C4 = 3; D4= 2,6
C5 = 4; D5= heute

Die Summe muss also 9 ergeben und nicht 13.

Das Problem ist, dass die Tabelle relativ lang ist, also wie oben schon
angedeutet mindestens 70 Reihen lang.
Ich danke für Tipps, Roland
 

Lesen sie die antworten

#1 Regina Henschel
12/04/2009 - 13:34 | Warnen spam
Hallo Roland,

Roland Leuschner schrieb:
Hallo an alle und frohe Ostern!
Wer kann helfen?
Ich soll eine Formel erstellen, die Folgendes ausrechnet:

Gegeben ist eine Tabelle. In der Spalte C stehen Zahlen. In der Spalte D
stehen mal Zahlen, mal Text, in willkürlicher Reihenfolge.

In z.B. C70 soll nun die Summe aus C stehen; es sollen aber nur die
Zahlen aus C berücksichtigt werden, bei denen in der gleichen Reihe
(z.B. Reihe 7) in D eine Zahl steht. Steht hingegen in D Text, soll die
Zahl in C nicht berücksichtigt werden.

Ein Beispiel:
C3 = 6; D3= 5,2
C4 = 3; D4= 2,6
C5 = 4; D5= heute

Die Summe muss also 9 ergeben und nicht 13.

Das Problem ist, dass die Tabelle relativ lang ist, also wie oben schon
angedeutet mindestens 70 Reihen lang.



{=SUMME(C3:C5*ISTZAHL(D2:D5))}

Die {} werden nicht direkt eingegeben, sondern bedeuten, dass du
=SUMME(C3:C5*ISTZAHL(D2:D5))
als Matrixformel eingeben musst.

Es geht natürlich auch mit Hilfsspalte E mit jeweils En =ISTZAHL(Cn) und
dann
=SUMMEWENN(E3:E5;WAHR();C3:C5)

mfG
Regina

Ähnliche fragen