Calc: Summewenn()

02/04/2010 - 17:20 von Rico Heil | Report spam
Hallo beisammen,

ich steh grade auf dem Schlauch.
Eigentlich möchte ich etwas recht einfaches Lösen:

In einer Calc-Tabelle erfasse ich den Heizölverbrauch.
Dort gibt es u.a. diese Spalten:
A Datum
E Verbrauch (also die Füllmengendifferenz seit dem letzten Datum).

Nun möchte ich an einer anderen Stelle der Tabelle einfach zwei
Zeitpunkte eingeben können und den dazwischen aufgetretenen
Gesamtverbrauch ermitteln.
Es sollen also alle Werte aus Spalte E aufsummiert werden, in deren
Zeile gilt:
Startdatum <= Spalte A <= Enddatum

Etwas konkreter:
Startdatum in B210
Enddatum in B211
In Zelle B212 soll dann eine entsprechende Formel stehen.
Ich vermute, dass das mit Summewenn() gehen sollte, komme damit aber
nicht weit genug.

Ich kann in der Formel alle Werte mit A >= Startdatum aufsummieren:
=SUMMEWENN(A5:A194; ">= "&B210;E5:E194)

Auch alle Werte mit A <= Enddatum bekomme ich aufsummiert:
=SUMMEWENN(A5:A194; "<= "&B211;E5:E194)

Nun bràuchte ich die Möglichkeit, diese beiden Kriterien mit UND zu
verknüpfen. Ist das syntaktisch überhaupt möglich?
Gibt es hierfür vielleicht eine andere geeignetere Funktion?

Vielen Dank für alle Hinweise die zur Ergreifung der passenden Formel
führen!

Rico
 

Lesen sie die antworten

#1 Regina Henschel
02/04/2010 - 18:12 | Warnen spam
Hallo Rico,

Rico Heil schrieb:
Hallo beisammen,

ich steh grade auf dem Schlauch.
Eigentlich möchte ich etwas recht einfaches Lösen:

In einer Calc-Tabelle erfasse ich den Heizölverbrauch.
Dort gibt es u.a. diese Spalten:
A Datum
E Verbrauch (also die Füllmengendifferenz seit dem letzten Datum).

Nun möchte ich an einer anderen Stelle der Tabelle einfach zwei
Zeitpunkte eingeben können und den dazwischen aufgetretenen
Gesamtverbrauch ermitteln.
Es sollen also alle Werte aus Spalte E aufsummiert werden, in deren
Zeile gilt:
Startdatum<= Spalte A<= Enddatum

Etwas konkreter:
Startdatum in B210
Enddatum in B211
In Zelle B212 soll dann eine entsprechende Formel stehen.
Ich vermute, dass das mit Summewenn() gehen sollte, komme damit aber
nicht weit genug.

Ich kann in der Formel alle Werte mit A>= Startdatum aufsummieren:
=SUMMEWENN(A5:A194; ">= "&B210;E5:E194)

Auch alle Werte mit A<= Enddatum bekomme ich aufsummiert:
=SUMMEWENN(A5:A194; "<= "&B211;E5:E194)

Nun bràuchte ich die Möglichkeit, diese beiden Kriterien mit UND zu
verknüpfen. Ist das syntaktisch überhaupt möglich?
Gibt es hierfür vielleicht eine andere geeignetere Funktion?

Vielen Dank für alle Hinweise die zur Ergreifung der passenden Formel
führen!



Schau mal in der Hilfe unter SUMME. Dort ist ein passendes Beispiel
vorgeführt.

mfG
Regina

Ähnliche fragen