Forums Neueste Beiträge
 

Calc: Werte addieren, wenn andere Zelle bestimmten Wert hat.

05/11/2008 - 08:39 von Michael Schmarck | Report spam
Hallo.

Ich habe folgende Tabelle (die in echt natürlich größer ist…):

count name department
274 admin01 BTECH
122 super user USUPP
13 hmeiser CUST A
7 jdoe CUST B

Nun würde ich gerne zàhlen, wieviele Zeilen es gibt, die in der
Spalte "department" "CUST.*" stehen haben (wo diese Spalte also mit
"CUST" beginnt) und wo in der Spalte "count" ein Wert >= 5 und < 10
ist. In dem o.g. Beispiel wàre das Ergebnis also 1 (die 5. Zeile mit
"jdoe").

Ich bekomme es mit =ZÄHLENWENN() hin, eine Zeile dann zu zàhlen, wenn
z.B. in "department" "CUST.*" steht:

=ZÄHLENWENN(C1:C7;"CUST.*")

Aber schon mit "count >= 5 und count < 10" habe ich Probleme… :(

geht nicht: ZÄHLENWENN(A2:A9;">=5 && <10")
auch nicht: ZÄHLENWENN(A2:A9;">=5 UND <10")

Wie könnte ich wohl hinbekommen was ich möchte (möglichst ohne Makros *G*)?

Michael
 

Lesen sie die antworten

#1 Pit Zyclade
06/11/2008 - 14:54 | Warnen spam
Michael Schmarck schrieb:
...
Ich habe folgende Tabelle...

count name department
274 admin01 BTECH
122 super user USUPP
13 hmeiser CUST A
7 jdoe CUST B

Nun würde ich gerne zàhlen, wieviele Zeilen es gibt, die in der
Spalte "department" "CUST.*" stehen haben (wo diese Spalte also mit
"CUST" beginnt) und wo in der Spalte "count" ein Wert >= 5 und < 10
ist. In dem o.g. Beispiel wàre das Ergebnis also 1 (die 5. Zeile mit
"jdoe").

Ich bekomme es mit =ZÄHLENWENN() hin, eine Zeile dann zu zàhlen, wenn
z.B. in "department" "CUST.*" steht:

=ZÄHLENWENN(C1:C7;"CUST.*")

Aber schon mit "count >= 5 und count < 10" habe ich Probleme… :(

geht nicht: ZÄHLENWENN(A2:A9;">=5 && <10")
auch nicht: ZÄHLENWENN(A2:A9;">=5 UND <10")
...



Habs auch mehrmals probiert, es geht so nicht. "&&" gibts schon gar
nicht. Mit nur einem Bedingungsargument (="Kriterien") wie ">=5" klappt
es ja problemlos).

Ich denke, das topic muß anders formuliert werden, damit einer es liest...

Pit

Ähnliche fragen