chinesische Schriftzeichen in Tabellnfeldern

20/12/2009 - 13:04 von Seminar | Report spam
in einer Tabelle meiner ACCESS 2003 Datenbank tauchen plötzlich in einigen
Feldern eines Datensatzes Folgen aus chinesischen Schriftzeichen auf. Wenn
ich ein solches Feld mit dem korrekten Eintrag überschreibe, kommt die
Meldung "Der Suchschlüssel wurde in keinem Datensatz gefunden" Im Feld
Geburtstag dieses Datensatzes erscheint 30.12.1899. Die Daten waren
ursprünglich ok. was ist da passiert?
 

Lesen sie die antworten

#1 Karl Donaubauer
20/12/2009 - 13:25 | Warnen spam
Seminar wrote:
in einer Tabelle meiner ACCESS 2003 Datenbank tauchen plötzlich in
einigen Feldern eines Datensatzes Folgen aus chinesischen
Schriftzeichen auf. Wenn ich ein solches Feld mit dem korrekten
Eintrag überschreibe, kommt die Meldung "Der Suchschlüssel wurde in
keinem Datensatz gefunden" Im Feld Geburtstag dieses Datensatzes
erscheint 30.12.1899. Die Daten waren ursprünglich ok. was ist da
passiert?



Sind die Felder mit den chinesischen Zeichen Memofelder?

Wenn ja, dann sind die Zeiger auf die Daten kaputt und hast
du hoffentlich ein aktuelles Backup.
s. http://allenbrowne.com/ser-47.html und dort
"Symptom: Memo field contains strange characters."

Der 30.12.1899 ist übrigens der Tag 0 bei Datumsfeldern in Access/JET.
Wenn dort vorher Datümer drin standen, dann wurden die Werte also
auf 0 zurückgesetzt.

Als Ursache für solche Datenfehler sind am ehesten Netzwerkprobleme
in Verdacht. Kann das bei dir der Fall sein?

Servus
Karl
********* Ich beantworte keine Access-Fragen per Email. *********
Access-FAQ: http://www.donkarl.com

Ähnliche fragen