Chromium stürzt nach Start ab

12/12/2010 - 14:01 von Lewin Bormann | Report spam
Hallo,
seit einigen Tagen habe ich hier ein Problem mit Chromium, der
Beta-Version von Chrome, bei mir 9. Sobald ich Chromium starte,
erscheint kurz das Fenster, das sich innerhalb einer halben Sekunde
wieder schließt. Nach der Vefolgung der Vorgànge mir strace lauten die
paar letzten Zeilen vor Absturz:

poll([{fd, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd,
revents=POLLOUT}])
writev(13, [{"\24\0\6\0\377\0\0\0\357\1\0\0\0\0\0\0\0\0\0\0\1\0\0\0",
24}, {NULL, 0}, {"", 0}], 3) = 24
poll([{fd, events=POLLIN}], 1, -1) = 1 ([{fd, revents=POLLIN}])
read(13, "\1
\263\2\1\0\0\0!\0\0\0\0\0\0\0\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096)
= 36
read(13, 0x80e5fa0, 4096) = -1 EAGAIN (Resource
temporarily unavailable)
clock_gettime(CLOCK_MONOTONIC, {7281, 201860765}) = 0
gettimeofday({1292158255, 201892}, NULL) = 0
poll([{fd, events=POLLIN}, {fd, events=POLLIN}], 2, 0) = 0 (Timeout)
poll([{fd, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd,
revents=POLLOUT}])
writev(13, [{"*\2\3\0008\0 \4\355\30o\0+\0\1\0", 16}, {NULL, 0}, {"",
0}], 3) = 16
read(13, "\2\264\0027\0
\4\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096) = 96
read(13, 0x80e5fa0, 4096) = -1 EAGAIN (Resource
temporarily unavailable)
clock_gettime(CLOCK_MONOTONIC, {7281, 202341563}) = 0
gettimeofday({1292158255, 202373}, NULL) = 0
poll([{fd, events=POLLIN}, {fd, events=POLLIN}], 2, 0) = 0 (Timeout)
read(13, 0x80e5fa0, 4096) = -1 EAGAIN (Resource
temporarily unavailable)
clock_gettime(CLOCK_MONOTONIC, {7281, 212534430}) = 0
read(13, 0x80e5fa0, 4096) = -1 EAGAIN (Resource
temporarily unavailable)
gettimeofday({1292158255, 212603}, NULL) = 0
poll([{fd, events=POLLIN}, {fd, events=POLLIN}], 2, 0) = 0 (Timeout)
+++ killed by SIGSEGV +++
Speicherzugriffsfehler

wobei die letzten beiden Zeilen besonders interessant sind... Woher
kommt nun der SIGSEGV/Speicherzugriffsfehler [1]? Als ich Chromium
installiert hatte trat das nicht auf, und auch nach mehrfacher
Neuinstallation kommt der Fehler. Kann das mit einer Aktualisierung in
letzter Zeit zusammenhàngen? Ist euch ein solcher Bug bekannt? Habe ich
irgendetwas verbockt (bis auf dass ich nicht den stabilen Chrome
installiert habe)?

Vielen Dank,
LB
Visit my projects at http://dermesser.111mb.de
Für persönlichen Kontakt bitte <news~lewin-bormann.de> (~ = at)
Systeminfos: http://ubuntuone.com/p/Kxy/
 

Lesen sie die antworten

#1 Markus Wichmann
12/12/2010 - 23:48 | Warnen spam
Lewin Bormann schrieb:
Hallo,
seit einigen Tagen habe ich hier ein Problem mit Chromium, der
Beta-Version von Chrome, bei mir 9. Sobald ich Chromium starte,
erscheint kurz das Fenster, das sich innerhalb einer halben Sekunde
wieder schließt. Nach der Vefolgung der Vorgànge mir strace lauten die
paar letzten Zeilen vor Absturz:



[...]
+++ killed by SIGSEGV +++
Speicherzugriffsfehler

wobei die letzten beiden Zeilen besonders interessant sind... Woher
kommt nun der SIGSEGV/Speicherzugriffsfehler [1]?



Das ist einfach: chromium hat versucht, auf eine Speicherzelle
zuzugreifen, die gar nicht in den va-space gemappt war. Typisches
Problem: Nullpointer-Dereferenzierung.

Als ich Chromium
installiert hatte trat das nicht auf, und auch nach mehrfacher
Neuinstallation kommt der Fehler. Kann das mit einer Aktualisierung in
letzter Zeit zusammenhàngen? Ist euch ein solcher Bug bekannt? Habe ich
irgendetwas verbockt (bis auf dass ich nicht den stabilen Chrome
installiert habe)?




Geht es wieder, wenn du das private Config-Verzeichnis (~/.chromium oder
so) verschiebst? Wenn ja, war eines der Plugins/Addons im Eimer.

Wenn nicht, ist wohl eine der verwendeten Shared Libs dran schuld.
Installiere in dem Fall die Debug-Versionen der verwendeten Libs und
versuche, herauszukriegen, welche Lib hier segfaulted. Wobei die nicht
mal die schuldige sein muss, es könnte auch ein Fehler in einer der Libs
sein, durch die der Call Path geht.

Schlussendlich könnte es auch tatsàchlich sein, dass die instabile
Version bei dir diesen Bug hervorruft.

Vielen Dank,
LB



HTH,
Markus

Ähnliche fragen