Clientzertifikate für ISA 2006 um auf OWA 2003 zuzugreifen

03/11/2007 - 12:10 von Torsten Schulz | Report spam
Hallo,

ich habe einen ISA Server 2006 und möchte über diesen eine Exchange 2003 OWA
Veröffentlichung machen. Ich habe SSL Bridging konfiguriert, d.h. ich habe
auf dem Exchange und auf dem ISA Server ein Zertifikat installiert und
kommuniziere über SSL. Der Zugriff funktioniert auch.

Jetzt möchte ich zusàtzlich ein Clientzertifikat vom Nutzer abfragen.
Mein Ziel ist es dabei, das der Nutzer die Loginseite des ISA Servers nur
dann sieht wenn er ein Clientzertifikat hat. Danach soll er seinen
Nutzernamen und Passwort eingeben und auf die OWA Webseite zugreifen können.
Ich habe dafür im Weblistener „SSL Clientzertifikat anfordern“ aktiviert.
Jetzt bekomme ich auch nur noch die Loginseite angezeigt, wenn ich ein
Clientzertifikat auf dem Client installiert habe. Wenn ich aber meinen
Nutzernamen und Passwort eingebe erhalte ich die folgende Fehlermeldung:

Fehlercode: 403 Verboten. Fehler bei der Authentifizierung. Das zum
Herstellen einer SSL-Verbindung mit dem ISA Server-Computer verwendete
Clientzertifikat stimmt nicht mit den von Ihnen eingegebenen
Anmeldeinformationen überein, (12253)

Um Fehler bei den Zertifikaten auszuschließen, habe ich auf dem Exchange
Server im IIS Clientzertifikate voraussetzen aktiviert und habe mit dem
Client direkt auf den Exchange Server zugegriffen. Ich benötige das
Clientzertifikat, damit ich nach Name und Password gefragt werde, gebe ich
diese ein werde ich auf die OWA Seite gelassen.

Hat jemand eine Idee was ich machen muss, damit der Nutzer nur wenn er ein
Clientzertifikat besitzt auf die Loginseite des ISA Servers zugreifen kann
und sich dann mit Namen und Passwort am Exchange Server authentifiziert.

Ich bin für jede Hilfe dankbar.

Torsten
 

Lesen sie die antworten

#1 Jens Baier
03/11/2007 - 12:36 | Warnen spam
Hi,

Fehlercode: 403 Verboten. Fehler bei der Authentifizierung. Das zum
Herstellen einer SSL-Verbindung mit dem ISA Server-Computer verwendete
Clientzertifikat stimmt nicht mit den von Ihnen eingegebenen
Anmeldeinformationen überein, (12253)



Du musst ein Client Zertifikate Mapping einrichten, damit das Zertifikat 1:1
zu einem Usernamen zugeordnet wird.
http://technet2.microsoft.com/windo...x?mfr=true
Das ganze kannst Du im IIS einrichten (Registerkarte
Verzeichnissicherheit)

Gruss Jens
www.nt-faq.de

P.S.: In der englischen NG noch keinen Erfolg gehabt?

Ähnliche fragen