Cluster auf Server 2008 und iSCSI

10/06/2009 - 10:53 von Rainer | Report spam
Hallo zusammen.

Ich versuche einen Cluster mit Server 2008 und iSCSI aufzusetzten.
Ein Raidsystem der Firma Brownie mit TB und SCSI 3 ist an eine SCSI-Bridge
der Firma Paralan angeschlossen. Über den iSCSI-Initiator von Windows sind
die darauf befindlichen beiden LUN´s problemlos einzubinden und zu nutzen.

Bei der Clusterinstallation werden die Platten bereits nicht mit
eingebunden, mache ich es manuell bekomme ich die Fehlermeldung 1069 "Bei der
Clusterressource "Clusterdatentràger 1" im geclusterten Dienst oder in der
geclusterten Anwendung "Verfügbarer Speicher" ein Fehler aufgetreten."

Die Vorabtests sind wenig aussagekràftig, da ich für den ersten Test nur
einen Node verwende und dadurch viele Punkte nicht überprüft werden.

Hat dazu jemand eine Idee?

Gruß

Mono
 

Lesen sie die antworten

#1 Bernd Pfann [MS]
10/06/2009 - 11:53 | Warnen spam
"Rainer" wrote in message
news:
Hallo zusammen.

Ich versuche einen Cluster mit Server 2008 und iSCSI aufzusetzten.
Ein Raidsystem der Firma Brownie mit TB und SCSI 3 ist an eine SCSI-Bridge
der Firma Paralan angeschlossen. Über den iSCSI-Initiator von Windows
sind
die darauf befindlichen beiden LUN´s problemlos einzubinden und zu nutzen.

Bei der Clusterinstallation werden die Platten bereits nicht mit
eingebunden, mache ich es manuell bekomme ich die Fehlermeldung 1069 "Bei
der
Clusterressource "Clusterdatentràger 1" im geclusterten Dienst oder in der
geclusterten Anwendung "Verfügbarer Speicher" ein Fehler aufgetreten."

Die Vorabtests sind wenig aussagekràftig, da ich für den ersten Test nur
einen Node verwende und dadurch viele Punkte nicht überprüft werden.

Hat dazu jemand eine Idee?


[]
Ich nehme an, dass Du die Windows Server 2008 Enterprise Edition im Einsatz
hast und keinen Standard Server!

Aus der Ferne sehe ich zwei mögliche Probleme!

a) Auf die LUNs sind nicht alle Knoten berechtigt
b) Das Speichersystem macht keine saubere SCSI 3 Persistent Reservation

http://technet.microsoft.com/en-us/...y/dd197454(WS.10).aspx#BKMK_Hardware_Requirements

"Because improvements in failover clusters require that the storage respond
correctly to specific SCSI commands, the storage must follow the standard
called SCSI Primary Commands-3 (SPC-3). In particular, the storage must
support Persistent Reservations as specified in the SPC-3 standard."

Um der Sache auf die Spur zu kommen musst Du auf jeden Fall den Validation
Wizard gegen mit beiden Knoten laufen lassen. Auch müssen beide Knoten die
LUNs sehen. Davor noch auf einem der beiden Knoten die LUN mit einer
primàren Partition versehen und optimaler Weise mit NTFS formatieren.
Mit freundlichen Grüßen / Kind regards - Bernd Pfann (Microsoft)

This posting is provided "AS IS" with no warranties, and confers no
rights.

Ähnliche fragen