Combobox - Auswahl zuordnen, VBA, Excel 2003

16/01/2008 - 09:07 von Thomas Bauer | Report spam
Hallo,

ich möchte folgendes machen.

Combobox in Zelle E20
Die Eintràge sollen sein
Eintrag 1
Eintrag 2
Eintrag 3
Eintrag 4
Eintrag 5
Eintrag 6
Eintrag 7
Eintrag 8
Eintrag 9
Eintrag 10
Eintrag 11
Eintrag 12
Eintrag 13
Eintrag 14

Wenn ich jetzt Eintrag 9 auswàhle soll in Zelle D20 die Zahl 110
eingetragen werden.
Wenn ich jetzt Eintrag 10 auswàhle soll in Zelle D20 die Zahl 120
eingetragen werden.
Wenn ich jetzt Eintrag 11 auswàhle soll in Zelle D20 die Zahl 310
eingetragen werden.
Wenn ich jetzt Eintrag 12 auswàhle soll in Zelle D20 die Zahl 410
eingetragen werden.

Wie kann ich das in VBA realisieren?

Müsste es nicht eine Load Methode der Tabelle geben?


Private Sub cmbTest_Change()

End Sub

Private Sub Worksheet_Activate()
cmbTest.AddItem ("Eintrag 1")
cmbTest.AddItem ("Eintrag 2")
cmbTest.AddItem ("Eintrag 3")
cmbTest.AddItem ("Eintrag 4")
cmbTest.AddItem ("Eintrag 5")

End Sub

Private Sub Worksheet_SelectionChange(ByVal Target As Range)

End Sub


Grüße Thomas
 

Lesen sie die antworten

#1 Melanie Breden
16/01/2008 - 09:44 | Warnen spam
Hallo Thomas,

"Thomas Bauer"schrieb:








ich möchte folgendes machen.

Combobox in Zelle E20
Die Eintràge sollen sein
Eintrag 1
Eintrag 2
...

Wenn ich jetzt Eintrag 9 auswàhle soll in Zelle D20 die Zahl 110
eingetragen werden.
Wenn ich jetzt Eintrag 10 auswàhle soll in Zelle D20 die Zahl 120
eingetragen werden.

Wie kann ich das in VBA realisieren?
<<<

muss es zwingend VBA sein, oder reicht auch eine Formellösung?

Ich gehe mal davon aus, dass die ComboBox aus der Steuerelement-Toolbox-Symbolleiste ist.
Schreibe im Eigenschaftenfenster der ComboBox neben der LinkedCell-Eigenschaft den Bezug
der Ausgabezelle E20.

In D20 kannst du dann eine SVERWEIS-Formel anwenden, in der die Eintràge nebst
auszugebenden Werten in einer Matrix aufgeführt sind:

=SVERWEIS(E20;{"Eintrag 1"."1";"Eintrag 2"."2";"Eintrag 3"."3";"Eintrag 4"."4";"Eintrag 5"."5";
"Eintrag 6"."6";"Eintrag 7"."7";"Eintrag 8"."8";"Eintrag 9".110;"Eintrag 10".120;"Eintrag 11".310;
"Eintrag 12".410;"Eintrag 13".13;"Eintrag 14".14};2;FALSCH)



Mit freundlichen Grüssen
Melanie Breden

- Microsoft MVP für Excel -
www.melanie-breden.de
Das Excel-VBA Codebook 2007 http://tinyurl.com/2nwvod

Ähnliche fragen