ComputerName in winnt.sif muß bestätigt werden

21/10/2007 - 21:19 von Alexander Nietzschmann | Report spam
Hallo alle,

ich hab mir eine Unattended-Setup-CD für XP Home mit SP2 gebastelt. Es
klappt auch alles ganz prima, außer daß ich bei der Test-Installation
(in Parallels Workstation) immer nach dem Computernamen gefragt werde -
erst kommt bei T-33 Minuten (nach der Geràteinstallation) eine Meldung:

"Die unbeaufsichtige Installation kann nicht fortgesetzt werden, da ein
vom Systemadministrator angegebener Setupparameter entweder fehlt oder
ungültig ist usw usf."

Die kann ich mit OK wegklicken, und dann kommt ein Fenster, wo ich den
Computernamen eingeben soll: der gewàhlte Name TESTXP ist schon
vorgeblendet und ausgegraut, aber ich muß ihn mit "Weiter" bestàtigen.
Anschließend làuft der Rest vom Setup anstandslos durch.

Probeweise hab ich es mal mit einer komplet von nLite erstellten
Installation versucht, und es passiert genau dasselbe.

Ich hab bei "ComputerName" alle möglichen Varianten mit Leerzeichen,
Anführungszeichen und Groß-/Kleinschreibung ausprobiert - jeweils ohne
Ergebnis.

Hier meine winnt.sif:

=[Data]
AutoPartition=0
MsDosInitiated="0"
UnattendedInstall="Yes"

[Unattended]
UnattendMode=FullUnattended
OemSkipEula=Yes
OemPreinstall=Yes
UnattendSwitch=yes
TargetPath=\WINDOWS

[Display]
BitsPerPel = 16
Vrefresh = 60
Xresolution = 1024
Yresolution = 768

[GuiUnattended]
EncryptedAdminPassword=NO
OEMSkipRegional=1
TimeZone0
OemSkipWelcome=1

[UserData]
ComputerName=TESTXP
FullName="My Name"
OrgName="My Company"
ProductKey=xyz

[Identification]
JoinWorkgroupÚHEEME

[Networking]
InstallDefaultComponents=Yes
=
Hat jemand eine Idee, wo ich noch drehen könnte? Daran, daß ich in einer
virtuellen Umgebung und nicht auf "echter" Hardware installiere, kann es
ja wohl kaum liegen ...

Gruß, Alex
 

Lesen sie die antworten

#1 Alexander Nietzschmann
22/10/2007 - 18:23 | Warnen spam
Hi,

Alexander Nietzschmann schrieb:

Hat jemand eine Idee, wo ich noch drehen könnte? Daran, daß ich in einer
virtuellen Umgebung und nicht auf "echter" Hardware installiere, kann es
ja wohl kaum liegen ...



Problem ist gelöst: es fehlte eine Zeile

[GuiUnattended]
AdminPassword=blah

in der winnt.sif - die Fehlermeldung war da nur irreführend. Vielleicht
hilfts ja irgendwem.

Gruß, Alex

Ähnliche fragen