configure findet package nicht

16/04/2012 - 19:35 von Ralph Aichinger | Report spam
Ich versuche gerade einen Block für Gnuradio zu kompilieren, der
aus einem billigen DVB-T-Stick ein Software Defined Radio macht:

http://wiki.spench.net/wiki/Gr-baz#Source_code

Ich checke mein Zeug aus git aus, mache "bootstrap",
und starte ./configure.

...
...
checking pkg-config is at least version 0.18... yes
checking for GNURADIO_CORE... configure: error: Package requirements (gnuradio-core >= 3) were not met:

No package 'gnuradio-core' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GNURADIO_CORE_CFLAGS
and GNURADIO_CORE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Ich habe gnuradio-core installiert (aus Debian-Packages):

/etc/gnuradio/conf.d/gnuradio-core.conf
/usr/lib/libgnuradio-core.so.3.5.2.1
/usr/lib/x86_64-linux-gnu/libgnuradio-core.so.3.5.3
/usr/share/doc/libgnuradio-core3.5.2.1
...
...

Kann es sein, daß ./configure von dem lib/x86_64-linux-gnu/ verwirrt
wird? Oder was das sonst ist?

/ralph
 

Lesen sie die antworten

#1 Uwe Premer
16/04/2012 - 19:46 | Warnen spam
Ralph Aichinger schrieb am 16.04.2012 19:35 Uhr:
Ich versuche gerade einen Block für Gnuradio zu kompilieren, der
aus einem billigen DVB-T-Stick ein Software Defined Radio macht:

http://wiki.spench.net/wiki/Gr-baz#Source_code

Ich checke mein Zeug aus git aus, mache "bootstrap",
und starte ./configure.



Zwischenfrage:
was sagt:
./configure --help ?

Ich frage deshalb, ob man da vll. den Pfad der nicht gefundenen lib
mitgeben kann.

Uwe

Ähnliche fragen