CPAN Modul bei activstate perl installieren

15/08/2008 - 09:53 von Gerhard Wolf | Report spam
Hallo,

ich habe eben versucht das Modul:
http://search.cpan.org/~edpratomo/DBD-InterBase-0.48/InterBase.pm
Der ActiveState Server kennt dieses Modul nicht bzw. ppm findet es nicht.
Wie kann ich dieses Paket installieren?

Mit perl -MCPAN -e shell kommt folgendes heraus:

C:\>perl -MCPAN -e shell
Set up gcc environment - 3.4.4 (cygming special, gdc 0.12, using dmd 0.125)
CPAN: File::HomeDir loaded ok (v0.69)

cpan shell -- CPAN exploration and modules installation (v1.9205)
ReadLine support enabled

cpan> i /InterBase/
CPAN: Storable loaded ok (v2.18)
Going to read C:\Perl\cpan\sources\authors\01mailrc.txt.gz
CPAN: Compress::Zlib loaded ok (v2.008)
DONE
Going to read C:\Perl\cpan\sources\modules\02packages.details.txt.gz
Database was generated on Wed, 13 Aug 2008 10:02:49 GMT
CPAN: HTTP::Date loaded ok (v5.810)
DONE
Going to read C:\Perl\cpan\sources\modules\03modlist.data.gz
DONE
Going to write C:\Perl\cpan\Metadata
Bundle Bundle::DBD::InterBase (EDPRATOMO/DBD-InterBase-0.43.tar.gz)
Distribution EDPRATOMO/DBD-InterBase-0.43.tar.gz
Distribution EDPRATOMO/DBD-InterBase-0.48.tar.gz
Module DBD::InterBase (EDPRATOMO/DBD-InterBase-0.48.tar.gz)
Module DBD::InterBase::FAQ (EDPRATOMO/DBD-InterBase-0.43.tar.gz)
Module DBD::InterBase::GetInfo (EDPRATOMO/DBD-InterBase-0.48.tar.gz)
Module DBD::InterBase::TypeInfo (EDPRATOMO/DBD-InterBase-0.48.tar.gz)
Module SPOPS::DBI::InterBase (CWINTERS/SPOPS-0.87.tar.gz)
Module SPOPS::Import::DBI::TableTransform::InterBase
(CWINTERS/SPOPS-0.87.tar.gz)
9 items found

cpan> install DBD::InterBase
Running install for module 'DBD::InterBase'
Running make for E/ED/EDPRATOMO/DBD-InterBase-0.48.tar.gz
CPAN: LWP::UserAgent loaded ok (v5.810)
CPAN: Time::HiRes loaded ok (v1.9711)
Fetching with LWP:

http://ppm.activestate.com/CPAN/aut....48.tar.gz
CPAN: YAML::XS loaded ok (v0.26)
Alert: While trying to 'parse' YAML file
'C:\Perl\cpan\FTPstats.yml'
with 'YAML::XS' the following error was encountered:
Usage: YAML::XS::LibYAML::Load(yaml_str) at
C:\Perl\site\lib/YAML/XS.pm line 70.
 

Lesen sie die antworten

#1 Max Dittrich
15/08/2008 - 10:55 | Warnen spam
Gerhard Wolf wrote:
Hallo,

ich habe eben versucht das Modul:
http://search.cpan.org/~edpratomo/DBD-InterBase-0.48/InterBase.pm
Der ActiveState Server kennt dieses Modul nicht bzw. ppm findet es nicht.



Für Perl 5.6 und 5.8 gibt es eine etwas verstaubte Version (0.43) als
PPD auf Sourceforge unter
http://sourceforge.net/project/show...p?group_id…63&package_id156

Welche Perl-Version verwendest Du?

Grüsse,.max

Ähnliche fragen