Cube-Erstellung schlägt fehl: Keine Verbindung zu Analysis Server

03/12/2008 - 13:50 von resch | Report spam
Liebes Forum,

mein Setup ist Windows Server 2003 R2 S.E. mit SP2 und allen Updates, IIS,
.NET Framework 2 + 3 mit Service Packs und Aktualisierungen, IIS-aktiviertes
ASP, Project Server 2007 SP1 mit allen Updates und Infrastrukturupdates
infrastructureupdateforwindowssharepointservices3.0-kb951695-fullfile-x86.exe
und infrastructureupdateformicrosoftofficeservers-kb951297-fullfile-x86.exe.

Der Project-Server ist soweit funktionsfàhig. Es lassen sich Sites erstellen
und bearbeiten.
Nun soll die Cubeerstellung ermöglicht werden. (alles auf den selben
W2k3-Server mit drauf, auf dem bereits Project-Server làuft).
Diesbzgl. Servererweiterungen:

MS SQL Server 2005 Enterprise mit Upgradeoption SKUUPGRADE=1 installiert
(SQL Server, Analysis und Reporting Services und die Tools), mit SP2 und
allen Patches aktualisiert. (Bei der Installation die vorhandene
Project-Server-Instanz $SERVERNAME\OFFICESERVERS ausgewàhlt).

SQL Server Management Objects Collection (SQLServer2005_XMO.msi) installiert.

SSP-Admin account (wobei es sich um den Account "Netzwerkdienst" handelt)
zur Gruppe "SQLServer2005MSOLAPUser$SERVERNAME$OFFICESERVERS" hinzugefügt.

Per SQL Management Studio -> Analysis Services -> Server-Eigenschaften
SSP-Admin account (Netzwerkdienst) zur Gruppe "Sicherheit" hinzugefügt.

Des weiteren bin ich für den Analysis-Services-Kram dieser Anleitung
gefolgt: http://technet.microsoft.com/de-de/...97552.aspx


Die Erstellung des Repositorys erfolgte nach Option2 der Anleitung:
Option 2: Erstellen des Repositorys durch Erstellen einer SQL Server
2005-Datenbank

Unter Schritt 8 (wo die Gruppe OLAP Administrators benutzt werden soll)
konnte ich diese Gruppe nicht auswàhlen, da sie nicht vorhanden ist.
Stattdessen benutzte ich die Gruppe
SQLServer2005MSOLAPUser$SERVERNAME$OFFICESERVERS.

Hier stellt sich die Frage, ob sich die in der Anleitung beschriebene Gruppe
OLAP Administrators nicht auf ein Setup mit SQL Server 2000 statt 2005
bezieht, oder ob man in der System-Benutzerverwaltung manuell eine Gruppe
OLAP Administrators hinzufügen und diese dann unter Schritt 8 auswàhlen muß.
In letzterem Fall stellt sich die Frage, wo man überall noch diese Gruppe
einbinden muß, damit es einem Setup einer automatisch zur Verfügung stehenden
Gruppe dieses Namens entspricht (so wie in der Anleitung vorgesehen).

Vielleicht spielt es ja auch keine Rolle und es sollte prinzipiell mit der
von mir verwendeten Gruppe auch funktionieren.

Ein anderer Punkt, der mir nicht 100% klar ist, findet statt unter dem Schritt
"Konfigurieren von Analysis Services für die Verwendung einer SQL
Server-Repositorydatenbank".
Und zwar wàhle ich hier die zuvor erstellte Datenbank "Analysis Services
Repository" aus, was m.E. richtig sein sollte. Falls nicht, muß man eine
andere bereits existierende oder eine weitere neu zu erstellende Datenbank
auswàhlen?

Jedenfalls, nachdem ich die Anleitung abgearbeitet habe und den
Cubeerstellungsvorgang starte ("Servereinstellungen" auf der Project-Site)
erhalte ich immer die Meldung, daß keine Verbindung zu Analysis Services
hergestellt werden konnte.

Vielleicht mache ich auch bei den Cubeeinstellungen, kurz vor dem Abschicken
des Erstellungsvorgangs was falsch. Unter
http://technet.microsoft.com/de-de/...97606.aspx wird nicht genauer
darauf eingegangen. Was muß man denn bei "Analysis Services Server"
eingeben? $SERVERNAME (in meinem Fall wàre das CUBETEST) oder OFFICESERVERS?
CUBETEST\OFFICESERVERS geht jedenfalls nicht, da das Backslash nicht
akzeptiert wird. Bei "Zu erstellende Analysis-Services-Datenbank" nehme ich
an, kann man einen Namen frei wàhlen.

Noch eine Unklarheit:
Muß man zwischen den Analyses Services Konfigurationen und dem Konfigurieren
und Abschicken der Cubeerstellungsanforderung noch weitere Konfigurationen
vornehmen?

Hier noch die Ausgabe bei versuchter Cubeerstellung:
== Cubeerstellungsprozess wird initialisiert =[03.12.2008 13:45] Die Meldung zur Cubeerstellungsanfrage wurde der Project
Server-Warteschlange hinzugefügt.
== Pre-Build-Serverereignishandler wird überprüft und ausgeführt =[03.12.2008 13:45] Pre-Build-Serverereignishandler wird überprüft und
ausgeführt
== Struktur der Datenbank und des Cubes wird bestimmt =[03.12.2008 13:45] Die Initialisierung der Cubeerstellung wurde gestartet.
[03.12.2008 13:45] Die OLAP-Datenbank und Cubestruktur wurden erfolgreich
bestimmt.
== Datenbanken und Cubes werden erstellt =[03.12.2008 13:45] Die Cubeerstellungssitzung wurde gestartet.
[03.12.2008 13:46] Die Analysis Services-Sitzung wurde gestartet.
[03.12.2008 13:46] Fehler der Analysis Services-Sitzung: Die Verbindung mit
dem Analysis Services-Server "CUBETEST" konnte nicht hergestellt werden.
Fehler: Es kann keine Verbindung hergestellt werden. Stellen Sie sicher, dass
der Server ausgeführt wird.
== Prozess abgeschlossen =[03.12.2008 13:46] Fehler beim Erstellen der OLAP-Cubes. Fehler: Fehler der
Analysis Services-Sitzung: Die Verbindung mit dem Analysis Services-Server
"CUBETEST" konnte nicht hergestellt werden. Fehler: Es kann keine Verbindung
hergestellt werden. Stellen Sie sicher, dass der Server ausgeführt wird.


Ich hoffe mir kann jemand helfen.
 

Lesen sie die antworten

#1 resch
03/12/2008 - 16:07 | Warnen spam
Ich habe jetzt irgendwo gelesen, daß der Weg wie unter Option2 in der
Anleitung beschrieben wohl gar nicht funktionieren soll. Also habe ich es
über Option1 (mit der DSO9-Freigabe) versucht. Leider das gleiche Ergebnis.

Jetzt versuche ich es mal mit einem neuen Server und SQL Server 2008
Analysis Services. Aber vielleicht fàllt jemandem noch was zu dem 2005er
Setup ein.

Ähnliche fragen