CUPS - Drucker druckt nicht mehr

21/12/2008 - 19:29 von hermann-hoff | Report spam
Hallo,

ich benutze SuSE Linux 9.1 und CUPS v1.1.20. Seit kurzem bringt der
Drucker (Canon BJC-4300 lokal an paralleler Schnittstelle) keinen
Ausdruck mehr zu Papier.

Er hat das Drucken aber anscheinend nicht von jetzt auf gleich
sondern nach und nach aufgegeben. Ich musste nàmlich schon seit
einiger Zeit gelegentlich den Rechner (und den Druckjob) neu
starten, um einen Druckjob auszuführen, der in der Übersicht mit
"Auftrag wird verarbeitet" aufgeführt war, aber nie zu Papier kam.
Jetzt aber geht gar nichts mehr.

In der Druckerkonfiguration von YaST wird der Drucker auch korrekt
als Canon BJC-4300 an /dev/lp0 automatisch erkannt. Beim
Schnittstellentest druckt er auch "Hello, world", wie es sein soll.
Der Druckertest (Text- oder Graphikdruck) bricht aber ab mit der
Meldung:

"Wàhrend der Kommunikation mit dem CUPS-Server
beim Speichern der Warteschlange y2test ist ein
Fehler aufgetreten.
cups(File) DoRequest error: client-error-request-value-too-long"

Habe CUPS schon de- und reinstalliert, mit dem selben Ergebnis,
außer dass der Drucker jetzt in Anwendungsprogrammen (OpenOffice,
kprinter) nicht mehr zur Auswahl zur Verfügung steht. Aber das
dürfte wohl daran liegen, dass die Konfiguration nach dem fehl
geschlagenen Testdruck von YaST nicht gespeichert wurde.

In einem Forum bei www.cups.org habe ich gelesen, dass die
Verzeichnisse /var/log/cups und /var/spool/cups vorhanden sein
müssen, bevor CUPS gestartet wird. Die sind aber vorhanden und ich
würde auch vermuten, dass die bei der Installation von CUPS angelegt
werden sollten, wenn sie es nicht sind.

Ein weiterer Hinweis war, dass das /directory (ich vermute, damit
ist das Home-directory gemeint) voll sein könnte. Gibt es denn in
Linux Größenbeschrànkungen für Verzeichnisse (abgesehen von der
Partitionsgröße)?

Dann habe ich noch CUPS v1.3.9 runtergeladen. Das kriege ich aber
nicht vollstàndig kompiliert. Und jetzt bin ich mit meinem Latein am
Ende und hoffe, dass es hier jemand gibt, der mir weiter helfen
kann.

MfG
Hermann
 

Lesen sie die antworten

#1 Eckart Pluennecke
19/12/2008 - 00:43 | Warnen spam
wrote:


Hallo,

ich benutze SuSE Linux 9.1 und CUPS v1.1.20. Seit kurzem bringt der
Drucker (Canon BJC-4300 lokal an paralleler Schnittstelle) keinen
Ausdruck mehr zu Papier.



Suse 9.1 ist geringfügig veraltet und seit einiger Zeit ohne Support


Er hat das Drucken aber anscheinend nicht von jetzt auf gleich
sondern nach und nach aufgegeben. Ich musste nàmlich schon seit
einiger Zeit gelegentlich den Rechner (und den Druckjob) neu
starten, um einen Druckjob auszuführen, der in der Übersicht mit
"Auftrag wird verarbeitet" aufgeführt war, aber nie zu Papier kam.
Jetzt aber geht gar nichts mehr.



Klingt ganz danach, als ob eine Partition vollgelaufen wàre.

In der Druckerkonfiguration von YaST wird der Drucker auch korrekt
als Canon BJC-4300 an /dev/lp0 automatisch erkannt. Beim
Schnittstellentest druckt er auch "Hello, world", wie es sein soll.
Der Druckertest (Text- oder Graphikdruck) bricht aber ab mit der
Meldung:

"Wàhrend der Kommunikation mit dem CUPS-Server
beim Speichern der Warteschlange y2test ist ein
Fehler aufgetreten.
cups(File) DoRequest error: client-error-request-value-too-long"

Habe CUPS schon de- und reinstalliert, mit dem selben Ergebnis,
außer dass der Drucker jetzt in Anwendungsprogrammen (OpenOffice,
kprinter) nicht mehr zur Auswahl zur Verfügung steht. Aber das
dürfte wohl daran liegen, dass die Konfiguration nach dem fehl
geschlagenen Testdruck von YaST nicht gespeichert wurde.

In einem Forum bei www.cups.org habe ich gelesen, dass die
Verzeichnisse /var/log/cups und /var/spool/cups vorhanden sein
müssen, bevor CUPS gestartet wird. Die sind aber vorhanden und ich
würde auch vermuten, dass die bei der Installation von CUPS angelegt
werden sollten, wenn sie es nicht sind.

Ein weiterer Hinweis war, dass das /directory (ich vermute, damit
ist das Home-directory gemeint) voll sein könnte. Gibt es denn in
Linux Größenbeschrànkungen für Verzeichnisse (abgesehen von der
Partitionsgröße)?



Nein, aber was sagt denn df zu deinen Partitionen? Bei mir hats mal /tmp
(das liegt in einer eigenen Partition) zu zugemüllt, dass erstmal fast gar
nix mehr ging. Vielleicht ist ja bei dir auch nur eine Parition ziemlich
voll.

Grüsse
Eckart

Ähnliche fragen