CUPS macht sich selbständig

02/04/2015 - 17:01 von Volker Englisch | Report spam
Hallo!

Zum einen - ich habe einiges an Unix-Erfahrung auf Servern, allerdings
nicht mit CUPS. Im Moment mache ićh gerade erste Gehversuche mit Linux
auf einem Client (Ubuntu 14.04 LTS) und könnte an CUPS verzweifeln.

Im lokalen Netz gibt es Drucker, die über Windowsfreigaben im LAN (ohne
Benutzeranmeldung) erreichbar sind. Ich richte also in Ubuntu einen
Drucker ein, als Ziel trage ich z.B. smb://WINSERVER/LJ4 ein.

Sehe ich mir dann /etc/cups/printers.conf an, findet sich bei dem
Drucker die Zeile:

AuthInfoRequired username,password

Egal, ob ich diese Zeile auskommentiere oder durch "AuthInfoRequired
none" ersetze: Direkt nach Änderung und Neustart von CUPS funktioniert
es, ich kann über diesen Drucker drucken. Bisher habe ich nicht
herausgefunden, woran es liegt, aber irgendwann steht bei dem Drucker
plötzlich wieder "AuthInfoRequired username,password", und bei einem
Druckversuch kommt das Dialogfenster, das unsinnigerweise nach
Benutzernamen und Passwort fragt.

In Google habe ich keine Lösung gefunden, nur Leute, die das gleiche
Problem haben. Was zum Geier löst diesen Automatismus aus, und wie
bekomme ich ihn weg - auf dass "AuthInfoRequired username,password" nie
mehr in der printers.conf aufscheinen möge...

TIA
Volker
 

Lesen sie die antworten

#1 Andreas Kohlbach
02/04/2015 - 22:35 | Warnen spam
Volker Englisch wrote on 02. April 2015:

Zum einen - ich habe einiges an Unix-Erfahrung auf Servern, allerdings
nicht mit CUPS. Im Moment mache ićh gerade erste Gehversuche mit Linux
auf einem Client (Ubuntu 14.04 LTS) und könnte an CUPS verzweifeln.

Im lokalen Netz gibt es Drucker, die über Windowsfreigaben im LAN
(ohne Benutzeranmeldung) erreichbar sind. Ich richte also in Ubuntu
einen Drucker ein, als Ziel trage ich z.B. smb://WINSERVER/LJ4 ein.

Sehe ich mir dann /etc/cups/printers.conf an, findet sich bei dem
Drucker die Zeile:

AuthInfoRequired username,password

Egal, ob ich diese Zeile auskommentiere oder durch "AuthInfoRequired
none" ersetze: Direkt nach Änderung und Neustart von CUPS funktioniert
es, ich kann über diesen Drucker drucken. Bisher habe ich nicht
herausgefunden, woran es liegt, aber irgendwann steht bei dem Drucker
plötzlich wieder "AuthInfoRequired username,password", und bei einem
Druckversuch kommt das Dialogfenster, das unsinnigerweise nach
Benutzernamen und Passwort fragt.



Möglicherweise überschreibt CUPS die Einstellungen, weil er noch lief,
als du Änderungen machtest.

Fahre ihn mal herunter

systemd stop cups

und schau, ob er wirklich ist

ps ax | grep -i cups

(darf kein "/usr/sbin/cupsd -f" o.à. liefern)

bevor du etwas ànderst.

In Google habe ich keine Lösung gefunden, nur Leute, die das gleiche
Problem haben. Was zum Geier löst diesen Automatismus aus, und wie
bekomme ich ihn weg - auf dass "AuthInfoRequired username,password"
nie mehr in der printers.conf aufscheinen möge...



Einige schilderten das Problem (in Englisch) auf
<http://ubuntuforums.org/archive/ind....html>, und wie sie es
beseitigten. So weit ich das sehe durch das Deaktivieren von CUPS, bevor
man Änderungen macht. Wie ich oben vermute.
Andreas

I use a Unix based operating system, which means I get laid almost as often as I
have to reboot my computer.

Ähnliche fragen