CUPS zeigt keinen Dateinamen und Benutzer an

15/10/2016 - 13:50 von Michelle Konzack | Report spam
Moin Leute,

auf meinem neuen Intranet Server laeuft CUPS mit 3 Netzwerkdruckern.

Was muss man einstellen, das man in "Auftraege" neben dem Druckernamen

1) den Dateinamen -> Unbekannt
2) den Benutzer -> {job_originating_user_name}

sieht? Soweit ich mich erinnern kann hat CUPS seit mindestens 10 Jahren
noch nie was dort angezeigt, egal was fuer einen Drucker ich verwendet
habe (sind mehr als 40 verschiedene mittlerweile).

Nun ist es aber erforderlich, das CUPS das anzeigt, denn ich habe
mehrere Personen die ueber das Internet auf meinen Druckern drucken. Das
gleiche gillt auch fuer meinen Server.

Drucken mit

lpr -H "intranet.${SERVER}" -U michelle.konzack -C "${FILE}" "${FILE}"

bringt auch keine Veraenderung.

Danke im voraus

Michelle Konzack ITSystems
GNU/Linux Developer 0033-6-61925193
 

Lesen sie die antworten

#1 Sebastian Reinhardt
15/10/2016 - 14:30 | Warnen spam
Am 15.10.2016 um 13:46 schrieb Michelle Konzack:
Moin Leute,

auf meinem neuen Intranet Server laeuft CUPS mit 3 Netzwerkdruckern.

Was muss man einstellen, das man in "Auftraege" neben dem Druckernamen

1) den Dateinamen -> Unbekannt
2) den Benutzer -> {job_originating_user_name}

sieht? Soweit ich mich erinnern kann hat CUPS seit mindestens 10 Jahren
noch nie was dort angezeigt, egal was fuer einen Drucker ich verwendet
habe (sind mehr als 40 verschiedene mittlerweile).

Nun ist es aber erforderlich, das CUPS das anzeigt, denn ich habe
mehrere Personen die ueber das Internet auf meinen Druckern drucken. Das
gleiche gillt auch fuer meinen Server.

Drucken mit

lpr -H "intranet.${SERVER}" -U michelle.konzack -C "${FILE}" "${FILE}"

bringt auch keine Veraenderung.

Danke im voraus




Hallo,

Da Du ja "Linux Developer" bist, sollte das kein Problem sein: schau mal
hier [1]

Insbesondere die Section "Directives Valis Within Policy Sections"! Die
Werte für "JobPrivateValues" und "JobPrivateAccess" sind der Schlüssel.
Die musst Du mal in Deiner "cupsd.conf" prüfen. Setzte die Werte aus der
"Policy Section" mal probehalber alle auf "all" und probiere es aus.


[1] https://www.cups.org/doc/man-cupsd.conf.html

Mit freundlichen Grüßen

Sebastian Reinhardt

Ähnliche fragen