Cursor und Texteingabe lahmen [Kile und kate]

25/04/2008 - 10:50 von Jens-Olaf Lindermann | Report spam
Hallo NG,

kile und kate lahmen auf meinem System (mobile Athlon XP2400+, mittlerweile
Debian stable statt opensuse, KDE 3.5.5. 2.6.22-4-k7 kernel) - aber ich
hatte das Problem auch auf einer opensuse. Der Effekt tritt nicht immer
auf, allerdings kann ich ihn auch nicht eingrenzen: Man gibt Text ein, und
das/die Wort/e erscheinen stark verzoegert. Besonders aergerlich wird es
beim Loeschen, da man dann nicht einfach 'anhalten' kann.

top -U root bzw. user zeigt mir keine ungewoehnliche Belastung, ebensowenig
procinfo -D n1. Zuerst dachte ich an die Autovervollstaendigungs- und
andere Module bei kile und kate und habe sie ausgeknippst - Fehlanzeige.
Testweise hatte ich prelink und and deaktiviert - daran liegt es auch nicht.

Tipps? Ratschlaege? Hilfen?

Gruss Jens





Debian GNU/Linux 4.0 stable
 

Lesen sie die antworten

#1 arkascha
25/04/2008 - 16:05 | Warnen spam
Moin Moin,

Jens-Olaf Lindermann wrote:
kile und kate lahmen auf meinem System
Der Effekt tritt
nicht immer auf, allerdings kann ich ihn auch nicht eingrenzen: Man gibt
Text ein, und das/die Wort/e erscheinen stark verzoegert.



das hört sich stark nach einem schon lange existierenden Bug im
Syntaxhighlighting bzw den dafür verwendeten Parsern an.

Der Bug ist an vielen Stellen beschrieben, allerdings stark unterschiedlich
wegen des nur sporadischen Auftretens. Einige Eintràge gibt es dazu in
kdevelop-Bugzilla, da kdevelop ja kate als Editor nutzt.

Mein eigener Eindruck (bin auch betroffen):
- der Bug tritt nur bei bestimmten Parsern auf (bei mir Programmiersprachen)
- der Bug ist zu exotisch und zu sporadisch um gefixt zu werden
- der Bug tritt _eher_ auf, wenn man Text mit vielen Klammerungen tippt
- der Bug tritt nur Montags an geraden Tageszahlen, ausgenommen Dienstag ist
ein Feiertag (oder so àhnlich).

Sorry, ich habe mich auch schon wundgesucht und Bugeintràge gemacht.
Scheinbar ist die KDE-Lösung hierfür:
Wir warten bis KDE4, da unterstützt kdevelop nur noch c++ und java (oder
so), also geht das Problem weg. Schon peinlich...

arkascha

Ähnliche fragen