Darstellung UserForm komisch

17/02/2010 - 15:27 von Peter Janke | Report spam
Hallo,
ich habe folgenden Aufbau mit mehreren UserForms, eine davon wird
seltsam dargestellt. Kann mir jemand schreiben, warum?

Eine Userform1 mit einem CommandButton1 wird beim Aktivieren des
Tabellenblatts 1 gestartet
UserForm1.show vbmodeless

Bei Click auf CommandButton1 wird eine UserForm2 mit einem
CommandButton2 gestartet.
private sub CommandButton1_Click()
UserForm2.show vbmodeless
end sub

Bei Click auf CommandButton2 wird eine UserForm3 mit einem
Bezeichnungsfeld1 gestartet, da steht dann drin "Bitte warten". Diese
UserForm3 erscheint auf dem Bildschirm, aber ohne das
Bezeichnungsfeld1. Auch eine Farbànderung des Hintergrundes der
UserForm3 wird nicht dargestellt.
private sub CommandButton2_Click()
UserForm3.show vbmodeless
weiterer Code
Userform3.hide
end sub

Warum wird diese UserForm3 so seltsam dargestellt? Wenn ich sie z.B.
mit Aktivierung des Tabellenblattes 2 starte, erscheint sie völlig
normal.

Gruß
Peter
 

Lesen sie die antworten

#1 Andreas Killer
17/02/2010 - 17:23 | Warnen spam
On 17 Feb., 15:27, Peter Janke wrote:

ich habe folgenden Aufbau mit mehreren UserForms, eine davon wird
seltsam dargestellt. Kann mir jemand schreiben, warum?


Tja, ich vermute mal nicht.

Bei solchen Problemen ist es oft hilfreich eine neue leere Mappe zum
machen, dort den gerade so nötigen Code zu platzieren etc. und dann
kucken ob's auch so aussieht. Wenn ja, dann die Mappe bei einem
Filehoster http://www.google.com/search?q=Filehoster hochladen, damit
wir mal draufkucken können.

Andreas.

Ähnliche fragen