DataGridView und Tabpage Bug

28/04/2008 - 10:20 von Akiono | Report spam
Hallo,

ich habe folgendes Problem:

Ausgangsituation:
Ich habe verschiedene Datagridviews in Groupboxes (Dock fill) auf
Tabpages platziert. Die Datenbindung habe ich über den Designer
vorgenommen.DataSource: DataSet DataMember: Datatable.

Problem:
Die Datagridviews enthalten keine Daten, bzw. die Datenbindung
funktioniert nicht richtig.

1. Lösungshinweis:
Die Tabpages werden ja erst gezeichnet, wenn sie aufgerufen werden,
daraufhin habe ich die Datenbindung nochmals in den SourceCode
geschrieben, einerseits in die Form_Load() Methode andererseits
nochmals in die TabControl_SelectedIndexChanged() Methode.(Auch jede
mögliche Kombination ergab kein damit kein Ergebnis).

Trotzdem bleibt das Problem bestehen, die DataGridviews zeigen die
Daten der Datatable nicht an.

Dann habe ich mir über ein PropertyGrid die Datagridviews
Eigenschaften zur Laufzeit anzeigen lassen.
Ergebnis: die DataMember Eigenschaft ist eigentlich richtig. Die
Datasource Eigenschaft ist aber leer.


Ich hab im Moment leider keine Idee voran es liegen kann, bzw. wo das
Problem genau liegt.

Eine Recherche über google und in dieser Group ergab, leider nur den
1. Lösungshinweis.

Über Ideen und Anregungen bin ich sehr dankbar.

Viele Grüße
Akiono Wan
 

Lesen sie die antworten

#1 Ulf Kadner
28/04/2008 - 10:49 | Warnen spam
Akiono wrote:

Ausgangsituation:
Ich habe verschiedene Datagridviews in Groupboxes (Dock fill) auf
Tabpages platziert. Die Datenbindung habe ich über den Designer
vorgenommen.DataSource: DataSet DataMember: Datatable.

Problem:
Die Datagridviews enthalten keine Daten, bzw. die Datenbindung
funktioniert nicht richtig.

1. Lösungshinweis:
Die Tabpages werden ja erst gezeichnet, wenn sie aufgerufen werden,
daraufhin habe ich die Datenbindung nochmals in den SourceCode
geschrieben, einerseits in die Form_Load() Methode andererseits
nochmals in die TabControl_SelectedIndexChanged() Methode.(Auch jede
mögliche Kombination ergab kein damit kein Ergebnis).

Trotzdem bleibt das Problem bestehen, die DataGridviews zeigen die
Daten der Datatable nicht an.



Hallo Akiono!

Also meines Erachtens hast Du da irgendwo nen Fehler gemacht.
Wenn ich z.B. in GridViews innerhalb der Tabpages drauf zugreife werden
diese so wie von mir erwartet ausgefüllt dargestellt. (Auch bei mehreren)

Mit welcher Framework-Version bzw. mit welcher IDE-Version tritt das so auf?

Hier mit VS2008 gegen Framework 2 + alle SP's kann ich das nicht
nachvollziehen.

MfG, Ulf

Ähnliche fragen