Daten in ein anderes Datenblatt übernehmen

04/10/2007 - 17:19 von Linus24 | Report spam
Hallo NG,
ich habe folgende Frage:
Ich habe ein Hauptdatenblatt mit über 300 Mitgliedern. In Zeile 2; B1
Vorname; C1 Vorname; D1 Strasse usw. Nun möchte ich in A1 ein "A" für
aktiv eingeben und diese Zeile soll dann automatisch in das
Tabellenblatt "Aktive" kopiert werden. Wenn ich in A1 ein "G" für
Gast eingebe soll diese Zeile automatisch in das Datenblatt "Gast"
übertragen werden. Wie stelle ich das an? und noch ne Frage: wenn
ich im Hauptdatenblatt den Namen àndern muss wegen Heirat oder so,
soll der neue Name in den entsprechenden Datenblàttern auch
automatisch geàndert werden. Könnt Ihr mir weiterhelfen?
Vielen Dank für Euere Bemühungen
Linus
 

Lesen sie die antworten

#1 Klaus \Perry\ Pago
04/10/2007 - 23:01 | Warnen spam
"Linus24" schrieb im Newsbeitrag
news:
Hallo NG,
ich habe folgende Frage:
Ich habe ein Hauptdatenblatt mit über 300 Mitgliedern. In Zeile 2; B1
Vorname; C1 Vorname; D1 Strasse usw. Nun möchte ich in A1 ein "A" für
aktiv eingeben und diese Zeile soll dann automatisch in das
Tabellenblatt "Aktive" kopiert werden. Wenn ich in A1 ein "G" für
Gast eingebe soll diese Zeile automatisch in das Datenblatt "Gast"
übertragen werden. Wie stelle ich das an? und noch ne Frage: wenn
ich im Hauptdatenblatt den Namen àndern muss wegen Heirat oder so,
soll der neue Name in den entsprechenden Datenblàttern auch
automatisch geàndert werden. Könnt Ihr mir weiterhelfen?
Vielen Dank für Euere Bemühungen



Hallo Linus

hier eine Lösung mit Matrixformeln. Dein Hauptdatenblatt heisst Tabelle1 und
die Daten stehen ab Zeile 2. Um den Formelaufwand zu vereinfachen, ermittel
ich die Zeilennummer der mit "A" gekennzeichneten Zeilen.

Tabelle2:

A2:
=WENN(ZEILE(A1)>ANZAHL(WENN(Tabelle1!$A$2:$A$300="A";ZEILE($2:$300)));"";KKLEINSTE(WENN(Tabelle1!$A$2:$A$300="A";ZEILE($2:$300));ZEILE(A1)))

mit STRG SHIFT RETURN eingeben und bis A300 herunterkopieren.

B2: =WENN(ISTZAHL($A2);INDEX(Tabelle1!$A$1:$D$300;$A2;SPALTE(B2));"")
bis D2 nach rechts kopieren. Dann B2:D2 beliebig nach unten kopieren.

Die Bpaltenbereiche können leicht angepasst werden.

Tabelle3:
Die gleichen Formeln wie in Tabelle2. Für die Markierung mit "G" muss nur
das "A" in der ersten Formel in "G" geàndert werden (taucht 2mal in der
Formel auf)

Gruß
Klaus

Ähnliche fragen