Datenquelle hinzufügen geht nicht

26/04/2008 - 13:38 von Matthias | Report spam
Von: "Matthias" <webmaster@starflight-va.de>
Betreff: Datenquelle hinzufügen geht nicht
Datum: Freitag, 25. April 2008 22:17

Hallo,

ich versuche in VS2008 mein erstes Projekt mit einer Datenbank zu erstellen.
Scheitere aber leider schon am Anfang.
Ich möchte also, um nicht den SQL Server mitliefern zu müssen, eine
einfache access datenbank verwenden.

In VS2008 also eine Form mit einem DatagridView drauf erstellt. Im
DGV bei Aufgaben -> Projektdatenquelle hinzufügen gewàhlt.
Dann kommt ein Fenster wo man die Datenwuelle wàhlen kann.
Ich hab mich ganz links für Datenbank entschieden und auf Weiter geklickt.
Drunter steht :

Ermöglicht die Verbindung mit einer Datenbank und die Auswahl der
Datenbankobjekte für die Anwendung. Mit dieser Option wird ein DataSet
erstellt.

Ok...klick -> Weiter -> neues Fenster "Wàhlen Sie ihre Datenverbindung aus"
dort -> klcik auf "Neue Verbiindung..."
Wieder ein neues Fenster "Datenquelle auswàhlen" als Titel
Unter Datenquelle kann ich wàhlen

- Microsoft Access-Datenbankdatei
-Microsoft ODBC-Datenquelle
- Microsoft SQL Server
usw...

Hab dort "Microsoft Access-Datenbankdatei" gewàhlt und auf weiter geklickt.
Kommt wieder ein neues Fenster mit Titel " Verbindung hinzufügen"
Oben bei Datenquelle steht "Microsoft Access-Datenbankdatei (OLE DB)" und
daneben ein Button
namens "Andern..."
Darunter "Sonstiges" -> Connectionstring. Dahinter steht nix.
Hab dann unten auf "Testverbindung" geklickt...kommt ne Meldung
"Testverbindung erfolgreich".

Danach hab ich, Siegessicher wie ich war, auf OK geklickt und blöderweise
kommt
eine Messagebox "Das Format der Initialisierungszeichenfolge stimmt nicht
mit der Spezifikation überein, die bei Index '0' beginnt."

Hà ??? Wat willer von mir ?

Kann mir bitte jamnd verraten was ich da falsch mache ?

Danke
Matthias
 

Lesen sie die antworten

#1 Peter Fleischer
26/04/2008 - 21:33 | Warnen spam
"Matthias" schrieb im Newsbeitrag
news:

ich versuche in VS2008 mein erstes Projekt mit einer Datenbank zu
erstellen.
Scheitere aber leider schon am Anfang.
Ich möchte also, um nicht den SQL Server mitliefern zu müssen, eine
einfache access datenbank verwenden.



Da muss man aber die MDAC und die Jet in der passenden Version mitliefern.

In VS2008 also eine Form mit einem DatagridView drauf erstellt. Im
DGV bei Aufgaben -> Projektdatenquelle hinzufügen gewàhlt.
Dann kommt ein Fenster wo man die Datenwuelle wàhlen kann.
Ich hab mich ganz links für Datenbank entschieden und auf Weiter geklickt.
Drunter steht :

Ermöglicht die Verbindung mit einer Datenbank und die Auswahl der
Datenbankobjekte für die Anwendung. Mit dieser Option wird ein DataSet
erstellt.

Ok...klick -> Weiter -> neues Fenster "Wàhlen Sie ihre Datenverbindung
aus"
dort -> klcik auf "Neue Verbiindung..."
Wieder ein neues Fenster "Datenquelle auswàhlen" als Titel
Unter Datenquelle kann ich wàhlen

- Microsoft Access-Datenbankdatei
-Microsoft ODBC-Datenquelle
- Microsoft SQL Server
usw...

Hab dort "Microsoft Access-Datenbankdatei" gewàhlt und auf weiter
geklickt.
Kommt wieder ein neues Fenster mit Titel " Verbindung hinzufügen"
Oben bei Datenquelle steht "Microsoft Access-Datenbankdatei (OLE DB)" und
daneben ein Button
namens "Andern..."
Darunter "Sonstiges" -> Connectionstring. Dahinter steht nix.
Hab dann unten auf "Testverbindung" geklickt...kommt ne Meldung
"Testverbindung erfolgreich".

Danach hab ich, Siegessicher wie ich war, auf OK geklickt und blöderweise
kommt
eine Messagebox "Das Format der Initialisierungszeichenfolge stimmt nicht
mit der Spezifikation überein, die bei Index '0' beginnt."

Hà ??? Wat willer von mir ?

Kann mir bitte jamnd verraten was ich da falsch mache ?



Schau dir mal den vom Designer generierten Code an.

Viele Gruesse

Peter

Ähnliche fragen