Datensatznavigation im geteilten Formular nicht möglich (A2007)

28/07/2009 - 17:29 von Sebastian Brandt | Report spam
Hallo zusammen,

ich habe ein geteiltes RG-Formular, in welchem ich nicht zum nàchsten
Datensatz navigieren kann. In der Listenansicht ja, nicht aber mit den
Navigationsschaltflàchen im Formular auch nicht mit DoCmd.GoToRecord , ,
acNext.

Weder der nàchste, letzte noch erste oder vorherige Datensatz gehen.
Eine Eingabe der Datensatz-Nr. quittiert Access mit »*Sie können nicht
zu demm angegebenen Datensatz springen.* Möglicherweise befinden Sie
sich am Ende eines Recordsets..«

Schalte ich die Ansicht auf einzelnes Formular geht es wieder. Die
Abfrage die dahinter liegt:

SELECT tblRegAdressen.RegNr, [tblRegister].[SozID] &
Format([tblRegister].[RefID],"00") & Right([tblRegister].[RegNr],4) &
[tblRegister].[SBID] & Left([tblRegister].[RegNr],2) AS codiert,
IIf(nz([Gegner]),IIf([gedreht]=True,[Gegner] & " ./. " &
[Mandant],[Mandant] & " ./. " & [Gegner]),[Mandant]) AS Betreff1,
tblRegAdressen.AdrSelID, tblRegAdressen.Betreff AS Betreff2,
tblAdressen.Anrede, tblAdressen.Vorname, tblAdressen.Nachname,
tblAdressen.Adresszusatz, tblAdressen.StrßID, tblAdressen.OrtID,
tblAdressen.AnrBriefkopf, tblAdressen.Grußformel, tblAdressen.Postfach,
tblAdressen.PFPLZ, tblAdressen.PFja, tblAdrSelektion.AdrErlàuterung,
tblAdressen.AdrNr, tblRegister.ESHeiHR AS WT, tblRegister.AktOID,
tblRegister.SelID, tblRegister.SozID, tblRegister.Gegenstandswert,
tblRegister.GBtrID, tblRegister.ESHeiHR, tblRegister.ESHeiDat,
tblRegister.PKH, tblRegister.VjDat, tblRegister.AblDat,
bswSortrg([AdrSelID]) AS Sortrg, tblAdressen.[Telefon 1],
tblAdressen.eMail, tblAdressen.[Telefon 2], tblAdressen.Telefax,
tblAdressen.Funk, tblAdressen.GebDatum, tblAdressen.Beruf,
tblAdressen.KundenNr, tblAdressen.RSV, tblAdressen.BLZ, tblBanken.Bank,
tblAdressen.Konto, tblAdressen.Einkommen, tblAdressen.RSVBtlgg,
tblAdressen.GebOrt, tblAdressen.Geburtsname, tblAdressen.StaatsA,
tblRegStandOrt.Dauer AS UDauer, IIf([14t]=True,"14tàgig","wöchentlich")
AS UTurnus, tblRegReferate.Referatsbezeichnung, tblSachbearbeiter.[SB
Vorname], tblRegStandOrt.Aktenstandort, tblSozietàt.Sozietàt,
tblRegSelektion.Selektionskennzeichen, tblRegister.Mandant,
tblRegister.Gegner, tblRegister.gedreht, tblRegister.AnlDat,
tblRegister.VjDat, tblRegister.Notiz, tblRegister.AblDat,
tblRegister.AblNr, tblRegister.Gegenstandswert, tblRegister.PKH,
tblRegister.ESHeiDat, tblRegister.ESHeiOrt, tblRegister.ESHeiHR,
tblRegister.ESGetrDat
FROM tblBanken RIGHT JOIN (tblRegSelektion INNER JOIN (tblSozietàt INNER
JOIN (tblSachbearbeiter INNER JOIN (tblRegReferate INNER JOIN
((tblAdrSelektion INNER JOIN (tblRegister INNER JOIN (tblAdressen INNER
JOIN tblRegAdressen ON tblAdressen.AdrNr = tblRegAdressen.AdrNr) ON
tblRegister.RegNr = tblRegAdressen.RegNr) ON
tblAdrSelektion.AdressSelektion = tblRegAdressen.AdrSelID) INNER JOIN
tblRegStandOrt ON tblRegister.AktOID = tblRegStandOrt.AktOID) ON
tblRegReferate.RefID = tblRegister.RefID) ON tblSachbearbeiter.SBIni =
tblRegister.SBID) ON tblSozietàt.SozID = tblRegister.SozID) ON
tblRegSelektion.SelID = tblRegister.SelID) ON tblBanken.BankID =
tblAdressen.BLZ
ORDER BY bswSortrg([AdrSelID]);

Hat jemand eine Ahnung woran das liegt?

Vielen Dank
Sebastian
 

Lesen sie die antworten

#1 Thomas Möller
28/07/2009 - 18:20 | Warnen spam
Hallo Sebastian,

Sebastian Brandt schrieb:
ich habe ein geteiltes RG-Formular, in welchem ich nicht zum nàchsten
Datensatz navigieren kann. In der Listenansicht ja, nicht aber mit den
Navigationsschaltflàchen im Formular auch nicht mit DoCmd.GoToRecord , ,
acNext.

Weder der nàchste, letzte noch erste oder vorherige Datensatz gehen.
Eine Eingabe der Datensatz-Nr. quittiert Access mit »*Sie können nicht
zu demm angegebenen Datensatz springen.* Möglicherweise befinden Sie
sich am Ende eines Recordsets..«

Schalte ich die Ansicht auf einzelnes Formular geht es wieder.



ich habe gerade versucht, die Situation bei mir nachzustellen. Bei mir
hat allerdings alles funktioniert. Ich habe es sogar mit einem Formular
mit Ufo erfolgreich testen können.
Mein Vorschlag: Erstell mal ein neues Formular auf Basis einer einfachen
Tabelle. Dort stellst Du dann die Eigenschaft "Standardansicht" auf
"Geteiltes Formular". Wenn jetzt die Navigation funktioniert weißt Du,
dass Deine Access-Installation grundsàtzlich in Ordnung ist. Als
nàchstes würde ich dann dem soeben erstellten Formular Deine Abfrage als
Datenquelle zuweisen und erneut testen.

CU
Thomas

Homepage: www.Team-Moeller.de

Ähnliche fragen