datum in spalte auszählen

25/02/2010 - 18:42 von Michael Feske | Report spam
Hallo alle zusammen,
ich trage über eine VBA Funktion mit jetzt() Datum und Uhrzeit in einer
Spalte ein.
Nun würde ich gerne in einer Zelle anzeigen lassen wieviele der Eintràge im
Datumsbereich "heute" und einer bestimmten Uhrzeit, zum Beispiel 08:00:00 -
10:00:00 liegen. Aus Zàhlenwenns bin ich leider nicht schlau genug geworden,
habt Ihr noch andere Ideen?

Gruß
Micha
 

Lesen sie die antworten

#1 Dietmar Vollmeier
25/02/2010 - 19:29 | Warnen spam
Guten Abend Michael!

*Michael Feske* schrieb am 25.02.2010 um 18:42 Uhr...
ich trage über eine VBA Funktion mit jetzt() Datum und Uhrzeit in einer
Spalte ein.
Nun würde ich gerne in einer Zelle anzeigen lassen wieviele der Eintràge im
Datumsbereich "heute"



=SUMMENPRODUKT(--(TEXT(A1:A10;"TT.MM.JJJJ")=TEXT(HEUTE();"TT.MM.JJJJ")))

und einer bestimmten Uhrzeit, zum Beispiel 08:00:00 -
10:00:00 liegen.



=SUMMENPRODUKT((STUNDE(A1:A10)>=8)*(STUNDE(A1:A10)<10))

In Kombination:
=SUMMENPRODUKT(--(TEXT(A1:A10;"TT.MM.JJJJ")=TEXT(HEUTE();"TT.MM.JJJJ"));(STUNDE(A1:A10)>=8)*(STUNDE(A1:A10)<10))

HTH
Servus | Wenn die Leute Hàuser so bauen würden, wie wir Programme
Didi | schreiben, würde der erstbeste Specht unsere Zivilisation
| zerhacken.

Ähnliche fragen