Datumsformel

15/06/2008 - 19:13 von Frank Bildstein | Report spam
Hallo allerseits,

in Zelle D4 kann ich über DropDown-Liste den Monat auswàhlen. In Zelle
A39 soll der 31.te eines Monats stehen, sofern er vorkommt. Dazu benutze
ich folgende Formel:
=WENN($D$4=0;"";WENN($D$4+30>MONATSENDE($D$4;0);"";WENN($D$4+30=SVERWEIS($D$4+30;Feiertag;1);SVERWEIS($D$4+30;Feiertag;3);$D$4+30)))

Als Fehlermeldung kommt in Zeile A39 jedoch #Name?

Was ist an der Formel falsch
 

Lesen sie die antworten

#1 {Boris}
15/06/2008 - 19:22 | Warnen spam
Hi Frank,

On 15 Jun., 19:13, Frank Bildstein wrote:

in Zelle D4 kann ich über DropDown-Liste den Monat auswàhlen. In Zelle
A39 soll der 31.te eines Monats stehen, sofern er vorkommt. Dazu benutze
ich folgende Formel:
=WENN($D$4=0;"";WENN($D$4+30>MONATSENDE($D$4;0);"";WENN($D$4+30=SVERWEIS($D­$4+30;Feiertag;1);SVERWEIS($D$4+30;Feiertag;3);$D$4+30)))

Als Fehlermeldung kommt in Zeile A39 jedoch #Name?

Was ist an der Formel falsch



Abgesehen davon, dass es imho für Dein Anliegen eine wesentlich
einfachere Variante gibt (wenn man das Vorhaben kennte), liegt der
Fehlerwert #NAME in der Verwendung der Funktion MONATSENDE begründet,
da diese Funktion zu den Analysefunktionen zàhlt und als
eigenstàndiges AddIn (über Extras-AddIns) eingebunden werden muss.
Seit xl2007 sind die Analysefunktionen übrigens fester Bestandteil des
Standardfunktionskataloges.

Grüße Boris

Ähnliche fragen