DBANZAHL? (Excel2007)

09/04/2010 - 17:20 von Oliver Hohl | Report spam
Hallo zusammen

Ich habe eine Tabelle, welche wie folgt aussieht
A B
1 X
1 X
1 X
2 X
2 X
3 X
3 X
Jetzt benötige ich eine Formel, damit ich folgendes Ergebnis erhalte:
A B
1 1 2
2 2 0
3 1 1
D.h. die X sollen gezàhlt werden und je Wert in der ersten Spalte
zusammengefasst werden. Ich bin über "Zàhlenwenn" zu "DBANZAHL" gekommen,
wurde aber aus der OH nicht wirklich schlau.

Kann mir jeman weiterhelfen?

Vielen Dank und viele Grüsse
Oliver
 

Lesen sie die antworten

#1 Claus Busch
09/04/2010 - 17:54 | Warnen spam
Hallo Oliver,

Am Fri, 9 Apr 2010 08:20:01 -0700 schrieb Oliver Hohl:

Ich habe eine Tabelle, welche wie folgt aussieht
A B
1 X
1 X
1 X
2 X
2 X
3 X
3 X
Jetzt benötige ich eine Formel, damit ich folgendes Ergebnis erhalte:
A B
1 1 2
2 2 0
3 1 1



probiere es mit Summenprodukt:
Für 1 und A:
=SUMMENPRODUKT(--(A1:A10=1);--(B1:B10="X"))
Für 1 und B:
=SUMMENPRODUKT(--(A1:A10=1);--(C1:C10="X"))
Für die anderen Werte analog anpassen. Statt A1:A10=1 kannst du auch den
Bezug für 1 in deiner neuen Tabelle angeben.


Mit freundlichen Grüssen
Claus Busch
Win XP PRof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen