dBase-Datenbank Abfrage/Sortierung mit "nicht sichtbaren Feldern"

08/05/2008 - 18:10 von Siegfried Höfner | Report spam
Hallo SO/OOo-Freunde,
ich habe meine privaten Adressdaten seit langem in einer
Datenbank im dBase-Format verwaltet und pflege das weiter
unter SO 5.2. Zur besseren Sortiermöglichkeit habe ich neben
dem Feld "Geburtstag" im Datumsformat noch 3 Felder
"Jahr","Monat","Tag" als Zahl (zu "Geburtstag").
Beim Erstellen einer Geburtstagabfrage gebe ich neben den
übrigen Feldern noch "Monat" und "Tag" mit "aufsteigend sortieren"
und "nicht sichtbar" an. So erhalte ich immer eine sortierte
Abfrage ohne Sicht der Kriterien.
Dasgleiche habe ich jetzt unter OOo-2.3.1 versucht und mußte
feststellen, daß nur ein "nicht sichtbares" Kriterium stehen bleibt,
das andere ist gelöscht worden, das Ergebnis ist damit natürlich falsch.
Getestet unter XP-Home und Vista-Home. Liegt es evtl. an meiner Version
oder besteht das Problem auch noch in spàteren Versionen. Weitere
Datenbanktypen habe ich noch nicht getestet.
Vielleicht kann das mal jemand nachstellen.

Gruß Siegfried
 

Lesen sie die antworten

#1 Siegfried Höfner
19/05/2008 - 11:49 | Warnen spam
"Siegfried Höfner" schrieb im Newsbeitrag news:fvv8m4$vlt$01$
Hallo SO/OOo-Freunde,
ich habe meine privaten Adressdaten seit langem in einer
Datenbank im dBase-Format verwaltet und pflege das weiter
unter SO 5.2. Zur besseren Sortiermöglichkeit habe ich neben
dem Feld "Geburtstag" im Datumsformat noch 3 Felder
"Jahr","Monat","Tag" als Zahl (zu "Geburtstag").
Beim Erstellen einer Geburtstagabfrage gebe ich neben den
übrigen Feldern noch "Monat" und "Tag" mit "aufsteigend sortieren"
und "nicht sichtbar" an. So erhalte ich immer eine sortierte
Abfrage ohne Sicht der Kriterien.
Dasgleiche habe ich jetzt unter OOo-2.3.1 versucht und mußte
feststellen, daß nur ein "nicht sichtbares" Kriterium stehen bleibt,
das andere ist gelöscht worden, das Ergebnis ist damit natürlich falsch.
Getestet unter XP-Home und Vista-Home. Liegt es evtl. an meiner Version
oder besteht das Problem auch noch in spàteren Versionen. Weitere
Datenbanktypen habe ich noch nicht getestet.



[Ingrid]
Gleiches Problem mit Datenbank /Calc. Es scheint so, daß niemand anderes
diese "Funktion" in der angegebenen Art und Weise benutzt!?

Gruß Siegfried

Vielleicht kann das mal jemand nachstellen.

Ähnliche fragen